summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGenki Sky2019-01-17 19:10:57 -0800
committerGenki Sky2019-01-17 19:11:24 -0800
commit8e2e217869d490e52d50a1178bdbb403ef5ea8b3 (patch)
tree39decce348ca07ee020be943f40b4c517700f44f /PKGBUILD
downloadaur-8e2e217869d490e52d50a1178bdbb403ef5ea8b3.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2021b427890
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Genki Sky <alt+archlinux.org@genki.is>
+
+pkgname=lingot-git
+pkgver=1
+pkgrel=1
+pkgdesc='LINGOT is a musical instrument tuner'
+arch=('i686' 'x86_64')
+url='http://nongnu.org/lingot/'
+license=('GPL2')
+depends=('gtk3')
+makedepends=('git' 'intltool')
+provides=('lingot')
+conflicts=('lingot')
+source=('git+https://git.savannah.nongnu.org/git/lingot.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd lingot
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd lingot
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd lingot
+ make DESTDIR="$pkgdir" install
+}