summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2019-12-16 22:46:21 -0500
committerGuillaume Horel2019-12-16 22:46:21 -0500
commit1f44b5227852c4ab9e9fe41e1c3b33b262c40cf1 (patch)
tree115972dc862cc3c2acdf13a7458d77f422ba656e /PKGBUILD
parent3df809ae88698ae032da7525b299e2a91bf81e9c (diff)
downloadaur-1f44b5227852c4ab9e9fe41e1c3b33b262c40cf1.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb1f8d79a85f..a27ca729118c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,19 @@
pkgname=linphone-git
_pkgname=linphone
-pkgver=4.3.0.alpha.r14.g2724e7bcf
+pkgver=4.4.0.alpha.r6.g0039298ee
pkgrel=1
pkgdesc="A Voice-over-IP phone library and CLI"
arch=('x86_64')
url="http://www.linphone.org"
license=('GPL')
-depends=('alsa-lib' 'bctoolbox-git' 'belcard-git' 'belle-sip-git' 'belr-git'
- 'bzrtp-git' 'ffmpeg' 'lime-git' 'libnotify' 'libpulse' 'libsoup' 'libv4l'
- 'libxv' 'mediastreamer-git' 'ortp-git' 'soci-git' 'speex' 'v4l-utils' 'xsd')
-makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'pkg-config' 'python-pystache')
+depends=('alsa-lib' 'bctoolbox>=4.3' 'belcard>=4.3' 'belle-sip>=4.3' 'belr>=4.3'
+ 'bzrtp>=4.3' 'ffmpeg' 'lime>=4.3' 'libpulse' 'libv4l'
+ 'libxv' 'mediastreamer>=4.3' 'ortp>=4.3' 'soci>=4.0' 'speex' 'v4l-utils' 'xerces-c')
+makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'python-pystache' 'xsd')
optdepends=('pulseaudio')
options=('!emptydirs')
-provides=('linphone')
+provides=("linphone=$pkgver")
conflicts=('linphone')
install=linphone.install
source=("git+https://github.com/BelledonneCommunications/linphone.git")
@@ -32,11 +32,9 @@ build() {
cd $_pkgname
CXXFLAGS="$CXXFLAGS -Wno-deprecated -Wimplicit-fallthrough=0 -Wno-unused-function"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_STATIC=NO \
-DENABLE_CXX_WRAPPER=YES \
-DENABLE_DOC=NO \
- -DENABLE_ROOTCA_DOWNLOAD=NO \
-DENABLE_LIME=YES \
-DENABLE_UNIT_TESTS=NO \
-DENABLE_STRICT=NO \