summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0b1001002021-12-28 14:58:07 +0100
committer0b1001002021-12-28 14:58:07 +0100
commit16eff311220e07d11fea8883b49b1d37945f0e8c (patch)
tree5b78702026416e4a68793b7a18948e32f762cfe9 /PKGBUILD
parent5de865813c3efc3ccd358e16c5728c25e720a347 (diff)
downloadaur-16eff311220e07d11fea8883b49b1d37945f0e8c.tar.gz
Add i686 support and fix path of errors.lir file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 972dc97a331d..2d181bdd0053 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=linrad
pkgver=05.01
-pkgrel=1
+pkgrel=2
pkgdesc="Software defined radio receiver for x11"
-arch=('x86_64')
+arch=('x86_64' 'i686')
url="https://www.sm5bsz.com/linuxdsp/linrad.htm"
license=('MIT')
depends=('portaudio' 'libxext' 'libusb-compat')
@@ -18,7 +18,7 @@ source=("$pkgname-$pkgver.tbz::https://www.sm5bsz.com/linuxdsp/archive/lir${pkgv
"$pkgname-gcc_11_1_0.patch")
sha512sums=('7b673c2c76122104dfe5a038f95e6a47a424796114ae4e8d3845987b486539803d63c1b9eeec00360fb5fa160304584644352d5853e6f74eeae81204ecf1afca'
'f1ce10d624f67bd4f2e243747c7bf180d4a70d27882ed4d574a905537182b9e1d684bb0853a8b96b3ebaaef1570348f25dbf7ed5c18737346af76848b1931a5d'
- 'c36890d23ceb992431fcd6944e03fa51f14c746f1542df94e67fe675eae18bb7dee14ad6239578f8a92dcbd1bcad4f1c4b1dc9e45dccb66d990c5777300f8ce2'
+ '1c661e4bea550ae496af121fc1c658cccc1fbe15c4aecb783641064729d5593f501fb977dff310739c9e303d4869ddafb36df3290c242df139560e6cbd4c661a'
'f147f48c7a8e7d90878d196ff01ec920fb823c753fe5db21efb1c442b2bed69c7c88e89ccf5ac0bc8d4e14ebfa33662d133e81a2b40c8238d7c3b4b1f06c1c67'
'fca3e6e8b70472d89d8100ce6d8d238898ee599053b97d967cb017532462c78aaeec3cbfbb7bbcb8cf21f8f05533de8515ff31a524275dee113c992c167aeec4')
@@ -29,7 +29,7 @@ prepare() {
# Fix path for help and error files
sed -i "s|help.lir|/usr/share/$pkgname/help.lir|g" menu.c help.c
- sed -i "s|errors.lir|/usr/share/$pkgname/linrad/errors.lir|g" help.c
+ sed -i "s|errors.lir|/usr/share/$pkgname/errors.lir|g" help.c
./clean
autoreconf -fiv
@@ -38,7 +38,11 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- make xlinrad64
+ if [[ "${CARCH}" == "x86_64" ]]; then
+ make xlinrad64
+ else
+ make xlinrad
+ fi
}
package(){
@@ -48,7 +52,7 @@ package(){
install -Dm755 $pkgname-wrapper.sh "$pkgdir/usr/bin/$pkgname"
cd "$pkgname-$pkgver"
- install -Dm755 xlinrad64 -t "$pkgdir/usr/bin/"
+ install -Dm755 xlinrad* "$pkgdir/usr/bin/x$pkgname"
install -Dm644 *.lir -t "$pkgdir/usr/share/$pkgname/"
install -Dm644 z_*.txt -t "$pkgdir/usr/share/doc/$pkgname/"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"