summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick2021-05-16 16:32:35 -0600
committerPatrick2021-05-16 16:32:35 -0600
commit6abc836703b9c258e8e6cbe2d15621fa02c6b9c7 (patch)
tree03699759568f9865534bd0dfa51073dc543c6721 /PKGBUILD
parent7fc7914660ddd58c9ec694fe417d20f43db99f41 (diff)
downloadaur-6abc836703b9c258e8e6cbe2d15621fa02c6b9c7.tar.gz
Add .desktop file to installation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1713efb1fcfd..7034862b06be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrick Rogers <patrick@thewebzone.net>
pkgname='linux-air-combat'
pkgver=08p47
-pkgrel=1
+pkgrel=2
pkgdesc="Free open source combat flight simulator"
arch=('any')
url="https://askmisterwizard.com/2019/LinuxAirCombat/IntroducingLinuxAirCombat.htm"
@@ -29,6 +29,7 @@ package() {
mkdir -p "$pkgdir/${_resource_dir}/sounds"
mkdir -p "$pkgdir/${_resource_dir}/models"
mkdir -p "$pkgdir/${_resource_dir}/textures"
+ mkdir -p "$pkgdir/usr/share/applications"
# Copying main executable file...
cp bin/Release/Lac${pkgver} $pkgdir/usr/bin/
mv $pkgdir/usr/bin/Lac${pkgver} $pkgdir/usr/bin/lac
@@ -51,4 +52,7 @@ package() {
cp bin/textures/* $pkgdir/${_resource_dir}/textures
chmod +r $pkgdir/${_resource_dir}/textures/*
+
+ cp lac.desktop $pkgdir/usr/share/applications/
+ chmod +r $pkgdir/usr/share/applications/lac.desktop
}