summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreggz2019-11-23 23:54:59 +0100
committereggz2019-11-23 23:54:59 +0100
commit3052ec905204ab357ac4d4ac3be7e2df0404e123 (patch)
tree3abada2e3b5f2c5658f5e382a8869acad127bc6d /PKGBUILD
parent68ed54ac9259812120afaa1f5811a2707c6530f2 (diff)
downloadaur-3052ec905204ab357ac4d4ac3be7e2df0404e123.tar.gz
Implemented gentoo genpatches for MZEN
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e2b3ca898c9..c32a5a320dd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=linux-amd-raven
_srcname=linux
gitver=v5.3.12
pkgver=5.3.v.12
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -18,12 +18,17 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
# the main kernel config files
'config.x86_64'
# standard config files for mkinitcpio ramdisk
- "${pkgbase}.preset")
+ "${pkgbase}.preset"
+ # patch from our gentoo overlords
+ '5012_enable-cpu-optimizations-for-gcc91.patch')
sha256sums=('SKIP'
#config.x86_64
- '17cfc62354c024fcf24ee58be4969babe57798a5310796b3d97ce4040337571d'
+ '2cc364d1395e1498312fe8d78f33a560990c543c4bd10d55dd4c69acab31cf7b'
#.preset file
- '0ac0cf410b0f3eeaa07d41505613e118ea59e01144e905f2dc0a808379f87e87')
+ '0ac0cf410b0f3eeaa07d41505613e118ea59e01144e905f2dc0a808379f87e87'
+ #patch file
+ 'fb98e49d7a640e05bf0d3a65ca49d0adb19de7547cb7ffca7a6cbacb1f461f0b'
+ )
_kernelname=${pkgbase#linux}
@@ -45,6 +50,9 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
+ # Implement cpu optimisation (MZEN2) patch from our gentoo lords
+ git apply ../5012_enable-cpu-optimizations-for-gcc91.patch
+
# get kernel version
yes "" | make prepare