summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2018-04-20 13:48:42 +1200
committeralzeih2018-04-20 13:48:42 +1200
commit2989d692b5728744206189a9275f9016b90539a4 (patch)
treee2547116caecb5b696471995dc396514b82fce88 /PKGBUILD
parent0794259691518444b08e3aa950ed23f6ed166d9b (diff)
downloadaur-2989d692b5728744206189a9275f9016b90539a4.tar.gz
updpkg: linux-apparmor 4.16.1-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04e53b5604b4..8c28a724b194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase=linux-apparmor
_srcname=linux-4.16
-pkgver=4.16
-pkgrel=2
+pkgver=4.16.1
+pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -12,7 +12,7 @@ makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(
https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
- #https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
+ https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
config # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
@@ -21,6 +21,7 @@ source=(
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
0003-Partially-revert-swiotlb-remove-various-exports.patch
+ 0004-Fix-vboxguest-on-guests-with-more-than-4G-RAM.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -28,14 +29,17 @@ validpgpkeys=(
)
sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
- 'd60cb7258ab632ab3ca25071266632970ae0ded00c1f4004fa8c6fc3547225c5'
+ '66931bd802eb8d9f09b1f36bb57f24abab13230469ee855e5aaa2f93be2022e0'
+ 'SKIP'
+ 'f61e5899ea360e0851d55d238c346f8c97d3344e7a38b437cc446629b1d01a9f'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1'
- '69be34b14df3275118e8c345d61b36b71370710c7b4f61bb3bedaff7501775f0'
- 'a4566321f73fa1448195691349d5ed0ddf30127d17213a31aa2c931e822df061'
- 'd365ce80dab359d5277bd2f8568cad50a30ab269f222ed1bb12b8d74571e24a6')
+ 'b172d6cabd8f1980f5ef4b5ad7a96a34e05d99fb02ec0565a80f96719f131a04'
+ '558c2b0fa7ad1761cb1dd89d8b860436f50d515c295949c08de9288100e034f6'
+ 'bc8a87cec67ecb8713d96167981c38d7ec4d93e1d2fdcb02193d704c441cff46'
+ 'c0fa1a6141bf64111ab9d0af4fc63d95b03b65baa2682aee1cd794d9311062c2')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -44,7 +48,7 @@ prepare() {
cd ${_srcname}
# add upstream patch
- #patch -p1 -i ../patch-${pkgver}
+ patch -p1 -i ../patch-${pkgver}
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -58,6 +62,9 @@ prepare() {
# NVIDIA driver compat
patch -Np1 -i ../0003-Partially-revert-swiotlb-remove-various-exports.patch
+ # https://bugs.archlinux.org/task/58153
+ patch -Np1 -i ../0004-Fix-vboxguest-on-guests-with-more-than-4G-RAM.patch
+
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n