summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2018-06-15 11:26:58 +1200
committeralzeih2018-06-15 11:26:58 +1200
commit42f1d3015eb93a1aaa22ce74c7a584aa3e40daec (patch)
treed2d086a2e7d8ea42a8d32f0fe901bfbee3a67b20 /PKGBUILD
parentce64ca5c7305738295f207684c72b272c0e1cd07 (diff)
downloadaur-42f1d3015eb93a1aaa22ce74c7a584aa3e40daec.tar.gz
updpkg: linux-apparmor 4.17.1-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c7dbdadd8dc..f88cdb18a031 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=linux-apparmor
#pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-4.17
-pkgver=4.17
+pkgver=4.17.1
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -13,7 +13,7 @@ makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(
https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
- #https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
+ https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
config # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
@@ -21,6 +21,7 @@ source=(
'config.fragment'
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
+ 0003-ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -28,13 +29,16 @@ validpgpkeys=(
)
sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
'SKIP'
+ '31f2f5309d99db632160538d43cf737166ae8b24c1b8091522ca1f9a804c25a1'
+ 'SKIP'
'0269d9a56f0d0306c9bd5c179a7e32214b0a1c082d3bca581661203b27305f17'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1'
- '0b77e6bef12735bc91e3f0e8232512e973688466f2e8a2c3a93502cb2d4b4eed'
- '92615acad59cbef9fd43b2710f5a77ffea45a86543ccff1b12eb676a9c8058cc')
+ 'e3c08f9b91611186e5ec579187ecea2a0143e5c2dc7ffc30ac6ea6e2b6d130fd'
+ '5403dead9161344b2c01027526146a250147680f4a2d32a54d40c55fc1becc8a'
+ 'd55e7de60b12bca26ded4c1bb8eb5860a9092374914a201a0f6a0ed2849d099f')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -43,7 +47,7 @@ prepare() {
cd ${_srcname}
# add upstream patch
- #patch -p1 -i ../patch-${pkgver}
+ patch -p1 -i ../patch-${pkgver}
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -54,6 +58,9 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
+ # https://bugs.archlinux.org/task/56780
+ patch -Np1 -i ../0003-ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch
+
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n