summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2017-12-14 22:02:08 +1300
committeralzeih2017-12-14 22:02:08 +1300
commit547ea9f444e5bb1001874a271ba7746fad75ac1b (patch)
tree48b56604ad61f992ea2ebc9908e81331f6d82c87 /PKGBUILD
parent1994603faa3bef01ada4ac6cc3de72dda145f78b (diff)
downloadaur-547ea9f444e5bb1001874a271ba7746fad75ac1b.tar.gz
upgpkg: linux-apparmor 4.14.5
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cb13ad605b0..2184c270a53f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-apparmor
_srcname=linux-4.14
-pkgver=4.14.4
+pkgver=4.14.5
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -20,6 +20,7 @@ source=(
'90-linux.hook' # pacman hook for initramfs regeneration
'linux.preset' # standard config files for mkinitcpio ramdisk
'config.fragment'
+ '0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -27,13 +28,14 @@ validpgpkeys=(
)
sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'SKIP'
- 'e9dcf9aad5977289940cd6e3762af02b87a725ba6c1a9f4af86958dc621e3a84'
+ 'd86eb2fd1c424fec9fbb12afacf7b783756651f5d7d0cf7ac71c3fbbbedddc9c'
'SKIP'
- 'a68e94064f040d60e8e4c3380efeee085b54d252d527e960dd17ac688505d5b6'
+ 'bfde21c325d39013463c38e9fa23d6d6481238b8509eea4ae38906127017e47d'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1')
+ '728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1'
+ '37b86ca3de148a34258e3176dbf41488d9dbd19e93adbd22a062b3c41332ce85')
_kernelname=${pkgbase#linux}
@@ -48,6 +50,9 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # disable USER_NS for non-root users by default
+ patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+
cp -Tf ../config .config
if [ "${_kernelname}" != "" ]; then