summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2018-08-20 23:17:17 +1200
committeralzeih2018-08-20 23:28:23 +1200
commit74b5b74d662a81cbb64906aaab272d145d219213 (patch)
tree45b1b3d1bd919ca0343f3f8dabbf57b1a69dad54 /PKGBUILD
parent5b9f585394dab1ebc0b5b7f62c953ba8e118408e (diff)
downloadaur-74b5b74d662a81cbb64906aaab272d145d219213.tar.gz
updpkg: linux-apparmor 4.17.12.arch1-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6dd3f8e48a7e..faba9018e953 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
pkgbase=linux-apparmor
#pkgbase=linux-custom # Build kernel with a different name
-_srcver=4.17.11-arch1
+_srcver=4.17.12-arch1
pkgver=${_srcver//-/.}
-pkgrel=2
+pkgrel=1
arch=(x86_64)
url="https://github.com/archlinux/linux/commits/v$_srcver"
license=(GPL2)
@@ -91,7 +91,8 @@ _package() {
# a place for external modules,
# with version file for building modules and running depmod from hook
- local extradir="$pkgdir/usr/lib/modules/extramodules$_kernelname"
+ local extramodules="extramodules$_kernelname"
+ local extradir="$pkgdir/usr/lib/modules/$extramodules"
install -Dt "$extradir" -m644 ../version
ln -sr "$extradir" "$modulesdir/extramodules"
@@ -107,7 +108,7 @@ _package() {
local subst="
s|%PKGBASE%|$pkgbase|g
s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extradir|g
+ s|%EXTRAMODULES%|$extramodules|g
"
# hack to allow specifying an initially nonexisting install file