summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2019-01-19 22:40:35 +1300
committeralzeih2019-01-19 22:40:35 +1300
commit7e1aaef8ad78a914b320f0766a8c3e08e4791941 (patch)
treef3d9d6a9995a099edf1607abe054954da838138f /PKGBUILD
parent0994b0ff68f38ae6685b6ac0de989a1ecc8def6f (diff)
downloadaur-7e1aaef8ad78a914b320f0766a8c3e08e4791941.tar.gz
updpkg: linux-apparmor 4.19.3.arch1-2:
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f4f4aa16fba..745ee6bf8167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgbase=linux-apparmor
#pkgbase=linux-custom # Build kernel with a different name
_srcver=4.19.3-arch1
pkgver=${_srcver//-/.}
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
@@ -81,13 +81,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"