summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2018-05-27 19:12:57 +1200
committeralzeih2018-05-27 19:13:10 +1200
commitae66dd77a7ae440bbf6ae2ee4d2a3875af8602b5 (patch)
tree3b82fbde9128cc117e8d1f8b61b001d0ce4eb3a2 /PKGBUILD
parent15c0a85a5032900d884b4ab94c2e1a2f35bfc0aa (diff)
downloadaur-ae66dd77a7ae440bbf6ae2ee4d2a3875af8602b5.tar.gz
updpkg: linux-apparmor 4.16.12-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6be423f202bc..03b8b5d97ef0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-apparmor
_srcname=linux-4.16
-pkgver=4.16.11
+pkgver=4.16.12
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -19,7 +19,8 @@ source=(
linux.preset # standard config files for mkinitcpio ramdisk
'config.fragment'
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+ 0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -27,15 +28,16 @@ validpgpkeys=(
)
sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
- 'd0d998f193c3feeab95f1378dea15aa6ba145f591661547cc00ef16d161651fe'
+ '70a6381aca28b1d271e85bc38fab05af4525d9fdc2c5bb87182b3351db8c4fa2'
'SKIP'
'e39c02fd021f125a6202f7e4c0692dfd3ced93d404ecb6c8dca6994c8e17b227'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1'
- 'b01e9bd4e0f3cc2b91db1d8c043b2d85329bd0c9a9441a91d337c3c33661b658'
- '09170daf49fe4cb720f331cd2da1c75771eb4f9f124353bf035218b1f8ca57d1')
+ '8d6a5f34b3d79e75b0cb888c6bcf293f84c5cbb2757f7bdadafee7e0ea77d7dd'
+ '2454c1ee5e0f5aa119fafb4c8d3b402c5e4e10b2e868fe3e4ced3b1e2aa48446'
+ '8114295b8c07795a15b9f8eafb0f515c34661a1e05512da818a34581dd30f87e')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -52,8 +54,11 @@ prepare() {
# disable USER_NS for non-root users by default
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ # https://bugs.archlinux.org/task/56780
+ patch -Np1 -i ../0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+
# https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ patch -Np1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"