summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle De'Vir2023-01-08 22:36:21 +1000
committerKyle De'Vir2023-01-08 22:36:21 +1000
commit442a6118ad138c5e32cba885102f648a57eb0af5 (patch)
treef4ad351f0bc7d5c7cf17addd1ab2d4aece97faf1 /PKGBUILD
parent0eb1ef9562c242184cdc4d65d2a29dccf577642a (diff)
downloadaur-442a6118ad138c5e32cba885102f648a57eb0af5.tar.gz
Don't download whole Arch Linux kernel
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 688fcaef0041..2a52f937c9eb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,7 +77,6 @@ options=('!strip')
_reponame="linux-bcachefs"
_repo_url="https://github.com/koverstreet/bcachefs.git"
-_reponame_arch="linux-archlinux"
_repo_url_arch="https://github.com/archlinux/linux.git"
_reponame_upstream="linux"
@@ -117,7 +116,7 @@ prepare() {
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- msg2 "Fetch and merge stable tag from Arch vanilla kernel repository..."
+ msg2 "Fetch and merge stable tag from ${_repo_url_arch} ..."
git remote add arch_stable "${_repo_url_arch}" || true
git fetch arch_stable "v${_srcver_tag%.*}-${_srcver_tag##*.}"
git merge --no-edit --no-commit FETCH_HEAD