summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle De'Vir2018-11-21 07:10:59 +1000
committerKyle De'Vir2018-11-21 07:10:59 +1000
commit5744b37f90ee12f354240f10a5094681cde83144 (patch)
treed86ecb2c48d12350d3e345d5be563219dd0732d6 /PKGBUILD
parent3ba7d9da238a531978d788f4cb6ae53401457181 (diff)
downloadaur-5744b37f90ee12f354240f10a5094681cde83144.tar.gz
Hide nconfig behind variable switch
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c571d470abd1..885afa822b32 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,12 @@
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
+### BUILD OPTIONS
+# Set these variables to ANYTHING that is not null to enable them
+
+# Tweak kernel options prior to a build via nconfig
+_makenconfig=
+
pkgbase=linux-bcachefs-git
_srcver=4.19.2-arch1
pkgver=${_srcver//-/.}
@@ -68,7 +74,7 @@ prepare() {
make -s kernelrelease > ../version
msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
- make nconfig
+ [[ -z "$_makenconfig" ]] || make nconfig
# save configuration for later reuse
cat .config > "${startdir}/config.last"