summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2019-11-06 15:39:07 +0100
committerPiotr Gorski2019-11-06 15:39:07 +0100
commit135f1ed0b8c2c80a3db390107dab27cd863e9aff (patch)
tree5e68837a4a416073494e1af6cdcfad9a3834cf5d /PKGBUILD
parent100b7361d8fcc045023e2a29f1e13d705b12c424 (diff)
downloadaur-135f1ed0b8c2c80a3db390107dab27cd863e9aff.tar.gz
Port more changes from linux trunk
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70981e9d3d1b..fcaa1756b3d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,8 @@ _major=5.3
_minor=9
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
-pkgrel=1
+pkgrel=2
+pkgdesc='Linux BFQ-dev'
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
license=('GPL2')
@@ -190,7 +191,7 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the BFQ-dev"
+ pkgdesc="The $pkgdesc kernel and modules"
depends=('coreutils' 'kmod' 'initramfs')
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
@@ -219,7 +220,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=('linux-bfq')
cd $_srcname
@@ -298,7 +299,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
depends=('linux-bfq')
cd $_srcname
@@ -308,8 +309,8 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
+ msg2 "Removing unneeded files..."
+ rm -rv "$builddir"/Documentation/{,output/}.[^.]*
msg2 "Moving HTML docs..."
local src dst