summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-22 20:44:02 +0100
committerPiotr Gorski2018-11-22 20:44:02 +0100
commit014edc8419dc11cdfc6df640c3445d943e82ca24 (patch)
tree2fde380ae525142b57311a10e183883d80d7cf65 /PKGBUILD
parente5ff4fe53c5a01f66ff2a4f07c6977953bbfe62c (diff)
downloadaur-014edc8419dc11cdfc6df640c3445d943e82ca24.tar.gz
Add vmlinuz symlink for systemd
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38caf2552c6c..528228e60a0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,7 +63,7 @@ _major=4.19
pkgver=4.19.3
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -270,13 +270,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"