summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2018-12-02 18:48:38 +0100
committerPiotr Gorski2018-12-02 18:48:38 +0100
commit60a2cf0e1db9b917093716c369253cd76558ff80 (patch)
tree0fb44e7f8da99847307698246361ff07034bcffc /PKGBUILD
parent730dbfef784c4446d457f04d5f1c06ee53942495 (diff)
downloadaur-60a2cf0e1db9b917093716c369253cd76558ff80.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 008f30724d9f..de0421467c35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,9 +25,7 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
-# begin making the pkg unless you're running modprobed-db (AUR) and building
-# this with makepkg as the user who is keeping the database.
+# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -66,7 +64,7 @@ _major=4.19
pkgver=4.19.6
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -239,11 +237,12 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ msg2 "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ -x /usr/bin/sudo ]] || {
+ echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
+ exit 1; }
+ sudo /usr/bin/modprobed-db recall
make localmodconfig
fi
fi