summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-24 00:05:28 +0100
committerPiotr Gorski2018-11-24 00:05:28 +0100
commitf9598d3f290f74cef1d38af90d20a33c71ae9a31 (patch)
tree26720a9cf12af1e309f60245a5c48df1bed4c26d /PKGBUILD
parentc8de5e878b9a745958936ebe2f1cb039bbd7eeeb (diff)
downloadaur-f9598d3f290f74cef1d38af90d20a33c71ae9a31.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6429ddc51e1..4d0d842163b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,9 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
+# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
+# begin making the pkg unless you're running modprobed-db (AUR) and building
+# this with makepkg as the user who is keeping the database.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -63,7 +65,7 @@ _major=4.19
pkgver=4.19.4
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -236,15 +238,13 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- msg "If you have modprobed-db installed, running it in recall mode now"
- if [ -e /usr/bin/modprobed-db ]; then
- [[ -x /usr/bin/sudo ]] || {
- echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
- exit 1; }
- sudo /usr/bin/modprobed-db recall
- fi
- msg "Running Steven Rostedt's make localmodconfig now"
+ if [ -f $HOME/.config/modprobed.db ]; then
+ msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ msg2 "Running Steven Rostedt's make localmodconfig now"
make localmodconfig
+ fi
fi
# save configuration for later reuse