summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2015-07-24 21:36:53 +0200
committerJoan Figueras2015-07-24 21:36:53 +0200
commitb1029c7903982b1b77b09971c637316d26543a26 (patch)
treeeeb55be6adad215e350b68059cbd88cc4c57b67e /PKGBUILD
parent8fcde03f9f86e2f696d35bb363c231df2c986c30 (diff)
downloadaur-b1029c7903982b1b77b09971c637316d26543a26.tar.gz
Update to 4.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d0786ec4366..3a0ce9ab8e56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgbase=linux-bld # Build kernel with a different name
_srcname=linux-4.1
pkgname=(linux-bld linux-bld-headers)
_kernelname=-bld
-pkgver=4.1.2
+pkgver=4.1.3
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/rmullick/linux"
@@ -33,11 +33,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://raw.githubusercontent.com/rmullick/bld-patches/master/${_BLDpatch}"
"0001-block-loop-convert-to-per-device-workqueue.patch"
"0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch"
+ '0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch'
+ 'bitmap-enable-booting-for-dm-md-raid1.patch'
)
sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
'SKIP'
- '1a8863e4cd7ef3d59b67061aaf5e3f98ad4c63dda015b9b483d458f2b673caef'
+ 'b949517b832af2fc90c57a35e475340f32c186f391cbdbfbe0aba7720dbb0b3e'
'SKIP'
'819961379909c028e321f37e27a8b1b08f1f1e3dd58680e07b541921282da532'
'f4c6a5c2fc0ee2b792e43f4c1846b995051901a502fb97885d2296af55fa193d'
@@ -49,7 +51,9 @@ sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
'4f30f76adbdf49aec8d41ac27ad212734500c272f3cba594f134a7bc263820d9'
'6b068476a99fa7b5902f20e379f28b0f72e7d8edb6b751b6b28d3d51bcb0e08b'
'9e1d3fd95d768a46353593f6678513839cedb98ee66e83d9323233104ec3b23f'
- 'bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81')
+ 'bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81'
+ '08f69d122021e1d13c31e5987c23021916a819846c47247b3f1cee2ef99d7f82'
+ '959c4d71b5dc50434eeecf3a8608758f57f111c6e999289c435b13fc8c6be5f0')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -88,6 +92,15 @@ prepare() {
patch -Np1 -i ../0001-block-loop-convert-to-per-device-workqueue.patch
patch -Np1 -i ../0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
+ # Fix bluetooth chip initialization on some macbooks (FS#45554)
+ # http://marc.info/?l=linux-bluetooth&m=143690738728402&w=2
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100651
+ patch -Np1 -i ../0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
+
+ # Fix kernel oops when booting with root on RAID1 LVM (FS#45548)
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100491#c24
+ patch -Np1 -i ../bitmap-enable-booting-for-dm-md-raid1.patch
+
msg2 "set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)"
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)