summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-28 01:18:07 +0200
committerPiotr Gorski2022-09-28 01:18:07 +0200
commit7b91a588101e09aeb23d4a2f179bb5b92311096d (patch)
tree4c4647f6232839c5851e64b41883c2d0a97a2757 /PKGBUILD
parentafaf3a3ec04569b3070ca64e67c836b9baa97d5f (diff)
downloadaur-7b91a588101e09aeb23d4a2f179bb5b92311096d.tar.gz
Improve nest and latency nice flags
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a74226457d46..4da57be2dcae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -272,11 +272,15 @@ if [ -n "$_bcachefs" ]; then
fi
## NEST Support
if [ -n "$_nest" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/sched/0001-NEST.patch")
+ fi
fi
## Latency NICE Support
if [ -n "$_latency_nice" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+ fi
fi
export KBUILD_BUILD_HOST=cachyos