summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Woudstra2023-06-24 09:15:11 +0200
committerEric Woudstra2023-06-24 09:16:07 +0200
commit3b2eea75962e1ecc5d79fd947021520e69b67baf (patch)
tree7fd3a03eb543e16daca75282303551efca86eda4 /PKGBUILD
parentae386ee7278b5b5628773d30ee6bb1c113681e3e (diff)
downloadaur-3b2eea75962e1ecc5d79fd947021520e69b67baf.tar.gz
Fix HS400 and add DEBUGFS setting
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fefd6c959f7..42ec2abad7a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,18 @@
# Succesfull boot also depends on devictree-overlays from:
# https://github.com/ericwoud/buildR64arch
+# Optional settings:
+#_lto="true" # Uncomment this line to enable CLANG-LTO
+#_debugfs="true" # Uncomment this line to set CONFIG_DEBUG_FS=y
+
pkgbase=linux-bpir64-git
_srcname=linux
_gitroot="https://git.kernel.org/pub/scm/linux/kernel/git/stable/${_srcname}"
_gitbranch="linux-rolling-stable"
_kernelname=${pkgbase#linux}
_desc="AArch64 kernel for BPI-R64 and BPI-R3"
-#_lto="true" # Uncomment this line to enable CLANG-LTO
pkgver=6.3.3.bpi
-pkgrel=1
+pkgrel=2
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -67,6 +70,7 @@ prepare() {
# sed -i 's/mt6795-sony-xperia-m5/mt7986a-bananapi-bpi-r3/g' ./arch/arm64/boot/dts/mediatek/Makefile
cp -vf ${startdir}/defconfig ./arch/arm64/configs/bpir_defconfig
+ [[ "$_debugfs" == "true" ]] && echo -e "\nCONFIG_DEBUG_FS=y" >>./arch/arm64/configs/bpir_defconfig
make ${MAKEFLAGS} $_llvm bpir_defconfig
rm -vf ./arch/arm64/configs/bpir_defconfig