summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Woudstra2023-11-08 21:00:30 +0100
committerEric Woudstra2023-11-08 21:00:30 +0100
commit4e7c670df421c329f4b4e3c2e26308501c9199a4 (patch)
tree1f19d9253e482fba34c87c3fc235ce71f667a795 /PKGBUILD
parent7da2c5620e1b819ed7a6119c85a202dc29257fde (diff)
downloadaur-4e7c670df421c329f4b4e3c2e26308501c9199a4.tar.gz
Allow changing branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f991a7dc9605..b42a466621a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,10 @@ fi
prepare() {
if [[ -d "${srcdir}/${_srcname}/" ]]; then
cd "${srcdir}/${_srcname}/"
- git fetch --all --depth=1
+ git remote set-branches origin '*'
+ git fetch --all -v --depth=1
+ git reset --hard
+ git checkout ${_gitbranch}
echo "LOCAL HEAD: $(git rev-parse HEAD)"
echo "REMOTE HEAD: $(git rev-parse @{u})"
if [ "$(git rev-parse HEAD)" != "$(git rev-parse @{u})" ]; then