summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Woudstra2023-03-14 22:04:57 +0100
committerEric Woudstra2023-03-14 22:04:57 +0100
commit674cb0825d05c5edd9ac522d853e73d5d9efb228 (patch)
tree6cd1b538af4a81329a7c9d3de854f88cf3c90afd /PKGBUILD
parentdf28bde2cf7eeba2c15902eccc6f3b176ac549dd (diff)
downloadaur-674cb0825d05c5edd9ac522d853e73d5d9efb228.tar.gz
setup initrd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 24 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb2df17ee5cc..65889d6c0e62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ _desc="AArch64 kernel for BPI-R64 and BPI-R3"
_r3dts="https://github.com/torvalds/linux/raw/master/arch/arm64/boot/dts/mediatek/mt7986a-bananapi-bpi-r3.dts"
_r3dtsi="https://github.com/torvalds/linux/raw/master/arch/arm64/boot/dts/mediatek/mt7986a.dtsi"
#_lto="true" # Uncomment this line to enable CLANG-LTO
-pkgver=6.2.2.bpi.r64.r3.1
-pkgrel=2
+pkgver=6.2.6.bpir
+pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -24,10 +24,14 @@ source=('defconfig'
'linux.preset'
'60-linux.hook'
'90-linux.hook'
+ 'mkinitcpio.conf'
+ 'mkinitcpio.hook'
+ 'mkinitcpio.build'
+ 'bpir3-flash2emmc'
)
-md5sums=(SKIP SKIP SKIP SKIP)
+md5sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP)
-export LOCALVERSION="-${pkgrel}"
+export LOCALVERSION=""
[[ "$_lto" == "true" ]] && _llvm="LLVM=1" || _llvm=""
@@ -136,6 +140,22 @@ _package() {
sed "${_subst}" ../linux.preset |
install -Dm644 /dev/stdin "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+ # install mkinitcpio conf file
+ sed "${_subst}" ../mkinitcpio.conf |
+ install -Dm644 /dev/stdin "${pkgdir}/etc/mkinitcpio-${pkgbase}.conf"
+
+ # install mkinitcpio runtime hook
+ sed "${_subst}" ../mkinitcpio.hook |
+ install -Dm644 /dev/stdin "${pkgdir}/etc/initcpio/hooks/${pkgbase}"
+
+ # install mkinitcpio build hook
+ sed "${_subst}" ../mkinitcpio.build |
+ install -Dm644 /dev/stdin "${pkgdir}/etc/initcpio/install/${pkgbase}"
+
+ # install R3 EMMC flash script
+ sed "${_subst}" ../bpir3-flash2emmc |
+ install -Dm755 /dev/stdin "${pkgdir}/usr/bin/bpir3-flash2emmc"
+
# install pacman hooks
sed "${_subst}" ../60-linux.hook |
install -Dm644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/60-${pkgbase}.hook"