summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2023-06-27 14:47:19 +0200
committerPiotr Gorski2023-06-27 14:47:19 +0200
commit027ddeb8f9edee05e461524f29d7be520e1861e1 (patch)
tree8eff1b24b14389b4a6ab045b39fcdb53f0448451 /PKGBUILD
parente3b3c2aba3f3e2178253c08016b45e73bcea93e0 (diff)
downloadaur-027ddeb8f9edee05e461524f29d7be520e1861e1.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbc8b276d3ca..b84c181a2b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,7 @@ _cachy_config=${_cachy_config-y}
# 'tt' - select 'Task Type Scheduler by Hamad Marri'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
# 'cachyos' - select 'EEVDF-BORE Variant Scheduler' EEVDF includes latency nice
+# 'eevdf' - select 'EEVDF Scheduler' EEVDF includes latency nice
_cpusched=${_cpusched-cachyos}
## Apply some suggested sysctl values from the bore developer
@@ -147,7 +148,7 @@ _zstd_level_value=${_zstd_level_value-normal}
# "full: uses 1 thread for Linking, slow and uses more memory, theoretically with the highest performance gains."
# "thin: uses multiple threads, faster and uses less memory, may have a lower runtime performance than Full."
# "none: disable LTO
-_use_llvm_lto=${_use_llvm_lto-}
+_use_llvm_lto=${_use_llvm_lto-none}
# Use suffix -lto only when requested by the user
# Enabled by default.
@@ -222,6 +223,8 @@ case "$_cpusched" in
cachyos) # CachyOS Scheduler (EEVDF + BORE)
source+=("${_patchsource}/sched/0001-EEVDF.patch"
"${_patchsource}/sched/0001-bore-eevdf.patch");;
+ eevdf) # EEVDF Scheduler
+ source+=("${_patchsource}/sched/0001-EEVDF.patch");;
pds|bmq) # BMQ/PDS scheduler
source+=("${_patchsource}/sched/0001-prjc-cachy.patch"
linux-cachyos-prjc.install);;
@@ -305,7 +308,7 @@ prepare() {
bmq) scripts/config -e SCHED_ALT -e SCHED_BMQ -d SCHED_PDS -e PSI_DEFAULT_DISABLED;;
tt) scripts/config -e TT_SCHED -e TT_ACCOUNTING_STATS;;
bore|hardened|cachyos) scripts/config -e SCHED_BORE;;
- cfs) ;;
+ cfs|eevdf) ;;
*) _die "The value $_cpusched is invalid. Choose the correct one again.";;
esac