summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2023-11-29 22:43:21 +0100
committerPiotr Gorski2023-11-29 22:43:21 +0100
commita35aebc3caab4e7f028cb0b5830b4fa50d13f3b0 (patch)
tree24273ae59a973b20d9fa736c2d148a6d2edef244 /PKGBUILD
parentadf239a4701e0a0293782242430a9b1722322efb (diff)
downloadaur-a35aebc3caab4e7f028cb0b5830b4fa50d13f3b0.tar.gz
Bump to 6.6.3
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd270f4ac9c1..d996e334e575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -170,7 +170,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.6
-_minor=2
+_minor=3
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -180,7 +180,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -202,7 +202,7 @@ if [ "$_cpusched" = "sched-ext" ]; then
fi
_patchsource="https://raw.githubusercontent.com/cachyos/kernel-patches/master/${_major}"
-_nv_ver=545.29.02
+_nv_ver=545.29.06
_nv_pkg="NVIDIA-Linux-x86_64-${_nv_ver}"
source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
@@ -218,7 +218,7 @@ fi
# ZFS support
if [ -n "$_build_zfs" ]; then
makedepends+=(git)
- source+=("git+https://github.com/cachyos/zfs.git#commit=043c6ee3b6bfb55f8d36e1f048ff13128c279fb8")
+ source+=("git+https://github.com/cachyos/zfs.git#commit=d38565b5ac3ecbf9dde7e8f7d71f4620a9cea9f9")
fi
# NVIDIA pre-build module support
@@ -679,9 +679,6 @@ build() {
local CONFIGURE_FLAGS=()
[ "$_use_llvm_lto" != "none" ] && CONFIGURE_FLAGS+=("KERNEL_LLVM=1")
- export KCPPFLAGS+=' -Wno-error=uninitialized'
- export KCFLAGS+=' -Wno-error=uninitialized'
-
./autogen.sh
sed -i "s|\$(uname -r)|${pkgver}-${pkgsuffix}|g" configure
./configure ${CONFIGURE_FLAGS[*]} --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin \
@@ -847,7 +844,6 @@ _package-schedulers() {
install -Dm755 scx_central "$pkgdir"/usr/bin/scx_central
install -Dm755 scx_flatcg "$pkgdir"/usr/bin/scx_flatcg
install -Dm755 scx_layered "$pkgdir"/usr/bin/scx_layered
- install -Dm755 scx_nest "$pkgdir"/usr/bin/scx_nest
install -Dm755 scx_pair "$pkgdir"/usr/bin/scx_pair
install -Dm755 scx_qmap "$pkgdir"/usr/bin/scx_qmap
install -Dm755 scx_rusty "$pkgdir"/usr/bin/scx_rusty
@@ -866,8 +862,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('88fc55107834d4308d33547211a031674ffaa8e48e23d6612ba39430292b18073d49271bd3ce8c7be01d8c5668482cb1715071abfd9b1f75b06468a09f8f4eec'
+b2sums=('cd0d70316592fface23a6eddb9d0f8b0c67593f5466388043ebd68613be4eabc3e7c712ce758fa63dd11603101d9d91e22b3552b436bbd1c76f8e19208d7bf22'
'5ddb5dcdb79354268e69d01523f06d5071538ba53171adcef0dd455b286df7785611d64f13b3aae06ac298cc60d990ebfa7b11d75dec9ab4a256b431de549483'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
- '1337c4884d270cd77ec0873c0e5fdeffc2ea174f88feb235ef661dbbcbf8f40bc298cc61aa2c44e9bf7d95b85958d20ae84a4b3613ea1a351e0741213affe41d'
+ 'e56bb1bbedd7db10d9b7dcc02bd1e121c6338533ddd16bd9c7aeae660d62004b6e0b02aee824325e974e94cdbaeefdad436eb284ebb3cdd825606631ae49134d'
'a1b4d2aa8bee8de58737843e9eca7d495fe9d621b13f8bc1e3058dc1e3d3f060984dd6ba87e393f5864a5e79a9ce8220d1c23b04323677c27cba0393bf61ab7d')