summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2023-12-11 15:58:45 +0100
committerPiotr Gorski2023-12-11 15:58:45 +0100
commited70bb431ca5eee930ed87f08517cb599d30b22a (patch)
treef0a8716088ee9d0e4e18c3a0bd31dbe224451905 /PKGBUILD
parent0779e6f82fbbc1b35566c3a349afa0764ef7f3aa (diff)
downloadaur-ed70bb431ca5eee930ed87f08517cb599d30b22a.tar.gz
Bump to 6.6.6
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d78ac09f497..256af1134d8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,7 @@
_cachy_config=${_cachy_config-y}
### Selecting the CPU scheduler
-# ATTENTION - one of six predefined values should be selected!
-# 'bmq' - select 'BitMap Queue CPU scheduler'
-# 'pds' - select 'Priority and Deadline based Skip list multiple queue CPU scheduler'
+# ATTENTION - only one of the following values can be selected:
# 'bore' - select 'Burst-Oriented Response Enhancer'
# 'tt' - select 'Task Type Scheduler by Hamad Marri'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
@@ -170,7 +168,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.6
-_minor=5
+_minor=6
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -198,6 +196,10 @@ if [[ "$_use_llvm_lto" = "thin" || "$_use_llvm_lto" = "full" ]] || [ -n "$_use_k
)
fi
+if [ "$_cpusched" = "sched-ext" ]; then
+ depends+=(scx-scheds)
+fi
+
_patchsource="https://raw.githubusercontent.com/cachyos/kernel-patches/master/${_major}"
_nv_ver=545.29.06
_nv_pkg="NVIDIA-Linux-x86_64-${_nv_ver}"
@@ -227,9 +229,6 @@ fi
case "$_cpusched" in
cachyos) # CachyOS Scheduler (EEVDF + BORE)
source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
- pds|bmq) # BMQ/PDS scheduler
- source+=("${_patchsource}/sched/0001-prjc-cachy.patch"
- linux-cachyos-prjc.install);;
tt) ## TT Scheduler
source+=("${_patchsource}/sched/0001-tt-cachy.patch");;
bore) ## BORE Scheduler
@@ -308,8 +307,6 @@ prepare() {
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
case "$_cpusched" in
- pds) scripts/config -e SCHED_ALT -d SCHED_BMQ -e SCHED_PDS -e PSI_DEFAULT_DISABLED;;
- bmq) scripts/config -e SCHED_ALT -e SCHED_BMQ -d SCHED_PDS -e PSI_DEFAULT_DISABLED;;
tt) scripts/config -e TT_SCHED -e TT_ACCOUNTING_STATS;;
bore|hardened|cachyos) scripts/config -e SCHED_BORE;;
eevdf) ;;
@@ -827,7 +824,7 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('9d66d720f2f037cfd480835ab38807fe5aabcff09bd210c5cb0dc80bd3e1182434df9f04a286df4e8cbc508ac984ecba12d2098a3296e3aac60afad94c085876'
+b2sums=('aef38e65d2bcccabb6d96691f96e5c0b3961e4e6125a33feb7ee99cd95c480984e35cc1e72bfa8da60ca76a40744054b8817012f6ebf85fc66161b802be73fb6'
'5ddb5dcdb79354268e69d01523f06d5071538ba53171adcef0dd455b286df7785611d64f13b3aae06ac298cc60d990ebfa7b11d75dec9ab4a256b431de549483'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
'96ab8ee123335565195fcb5a5e3448d01cd15da64002b321ee88f71c0f826913a7c8bf17bc46a49aaa5eef526b39bf589769a4590dac229621044f58833e5d07'