summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2023-05-01 11:31:31 +0200
committerPiotr Gorski2023-05-01 11:31:31 +0200
commit8a5989c32446a94171b72dca28f550a3d17c676b (patch)
tree4f2ceb75e4f44cc482b4f3b6c3f1cbb867d73ede /PKGBUILD
parent6e6f3706b27a235bcadc2e6f5538c481e34ee557 (diff)
downloadaur-8a5989c32446a94171b72dca28f550a3d17c676b.tar.gz
Bump to 6.3.1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 24 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a26fc8f327cc..9c02414f6755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -130,9 +130,6 @@ _use_auto_optimization=${_use_auto_optimization-y}
# disable debug to lower the size of the kernel
_disable_debug=${_disable_debug-}
-## Enable zram/zswap ZSTD compression
-_zstd_compression=${_zstd_compression-}
-
### Selecting the ZSTD kernel and modules compression level
# ATTENTION - one of two predefined values should be selected!
# 'ultra' - highest compression ratio
@@ -196,17 +193,17 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.3
-_minor=0
+_minor=1
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
-#_stable=${_major}.${_minor}
-_stable=${_major}
+_stable=${_major}.${_minor}
+#_stable=${_major}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux BMQ scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=5
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -280,12 +277,21 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
_die() { error "$@" ; exit; }
+_make() {
+ test -s version
+ make KERNELRELEASE="$(<version)" "$@"
+}
+
prepare() {
cd ${srcdir}/$_srcname
+ echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
+ make ${BUILD_FLAGS[*]} defconfig
+ make ${BUILD_FLAGS[*]} -s kernelrelease > version
+ make ${BUILD_FLAGS[*]} mrproper
local src
for src in "${source[@]}"; do
@@ -585,17 +591,6 @@ prepare() {
-d LRNG_RUNTIME_FORCE_SEEDING_DISABLE
fi
- ### Enable zram/zswap ZSTD compression
- if [ -n "$_zstd_compression" ]; then
- echo "Enabling zram/swap ZSTD compression..."
- scripts/config -d ZRAM_DEF_COMP_LZORLE \
- -e ZRAM_DEF_COMP_ZSTD \
- --set-str ZRAM_DEF_COMP zstd \
- -d ZSWAP_COMPRESSOR_DEFAULT_LZ4 \
- -e ZSWAP_COMPRESSOR_DEFAULT_ZSTD \
- --set-str ZSWAP_COMPRESSOR_DEFAULT zstd
- fi
-
### Selecting the ZSTD modules and kernel compression level
[ -z "$_zstd_level_value" ] && _die "The value is empty. Choose the correct one again."
@@ -658,12 +653,11 @@ prepare() {
### Rewrite configuration
echo "Rewrite configuration..."
- make ${BUILD_FLAGS[*]} prepare
- yes "" | make ${BUILD_FLAGS[*]} config >/dev/null
+ _make ${BUILD_FLAGS[*]} prepare
+ yes "" | _make ${BUILD_FLAGS[*]} config >/dev/null
diff -u ../config .config || :
### Prepared version
- make ${BUILD_FLAGS[*]} -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
### Running make nconfig
@@ -715,19 +709,18 @@ _package() {
cd ${srcdir}/$_srcname
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$(_make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ _make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
@@ -841,9 +834,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('ba3491f5ed6bd270a370c440434e3d69085fcdd528922fa01e73d7657db73b1e'
- '54d0470901596286036c20b1537754ba71885cad51452bcb9bf42b92b2175cbe'
- '41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106'
- 'a81babd189054ed217e58688612ad274ffc06f9912094b29be7f1442aa067d42'
- '75946e91f032c4e9186d56092a90abc90c14f16ef938d5201d425d8a31298aa1'
- 'a11c0100cc2f52a28f75bc788b3d7703f7224bb083465daa2d33403c1ff86697')
+b2sums=('91c7ac2fb2bdeed323b6f0812582bd82c78f62ce3754063716a8769b30c41e35ae06b042ef27fb3c59a63ca17ec764313d7971ba2ddf84f8cf9fe5885ffe0644'
+ '59b0697d3dce7b3bc75f9a096ada379a71cfd472775d9ebbb54c658a5aae756a631ec4b238b4b3dd9e503bda07b31ce5716643b8c57b21f45959f5f57eac7c1b'
+ '11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
+ 'c935d5008fe006e6fe0e6c2e04a3bdb71602472274cfd47bae8b877f95b3df5fb5a8c9aedbcef2b5761f22487f662e043ec74de4e63cf40e3e3bb4b9b37a2a72'
+ '8beaf8f1dee836ff2cdaf6874697f216099e5a427a7c2e3764bb084cb546ebf48f81b6bf83f3c7e7f1a9378264434ad2ed0c667b0bd3226e2c72ffa07d31d0fb'
+ '21f2753be26455812dde25232265a5660feed49751be36e1dcc1e6a9993de673380c2b210d58d4041096442f11080c7206846f140082e927284f6d001eea0d23')