summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2024-03-20 17:32:57 +0100
committerPiotr Gorski2024-03-20 17:32:57 +0100
commitaf5c5fb291dd62ec9ba0c333fcc3f1099d7a738b (patch)
treeb522824cb81ef75397aa689e1349b85c4ab98f85 /PKGBUILD
parent268f249ab8fce47991b33dede17335fe1690f402 (diff)
downloadaur-af5c5fb291dd62ec9ba0c333fcc3f1099d7a738b.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a954acf940d..6b9994a7642c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -168,7 +168,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=3
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -212,7 +212,8 @@ fi
# NVIDIA pre-build module support
if [ -n "$_build_nvidia" ]; then
- source+=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${_nv_ver}/${_nv_pkg}.run")
+ source+=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${_nv_ver}/${_nv_pkg}.run"
+ "${_patchsource}/misc/nvidia/0001-NVIDIA-take-modeset-ownership-early.patch")
fi
## List of CachyOS schedulers
@@ -252,6 +253,7 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
src="${src%.zst}"
+ [[ $src = 0001-NVIDIA-take-modeset-ownership-early.patch ]] && continue
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
@@ -521,6 +523,9 @@ prepare() {
if [ -n "$_build_nvidia" ]; then
cd "${srcdir}"
sh "${_nv_pkg}.run" --extract-only
+
+ # Temporary fix for nvidia module
+ patch -Np2 --no-backup-if-mismatch -i "${srcdir}/0001-NVIDIA-take-modeset-ownership-early.patch" -d "${srcdir}/${_nv_pkg}/kernel"
fi
}
@@ -709,5 +714,5 @@ done
b2sums=('2b518f8f39b4dcea1c580cb0664d59c165db989422fd6fd6b65d3dd1e4548bc6e0cedfc95c2584ae56f69ac1a1d3de6552ee61e77b08799a5275934a453ab929'
'8178cdd3224ca5b7ef9e971fdb403b57d4f4e44d3b9de31cf118bc1b195cf5d376b424cd5a5013c10182116b9ed18d09b893633ccf2486454d60bcced32149a0'
'43ef7a347878592740d9eb23b40a56083fa747f7700fa1e2c6d039d660c0b876d99bf1a3160e15d041fb13d45906cdb5defef034d4d0ae429911864239c94d8d'
- '2617ffcdb57df5d2537382b89036dc9786c139815d14da7b3a246e74b204c6e84c04648a596316b467c05304fef2368491a3553344cac5475504edccdac58257'
+ '5a02cc06ec593f62c497445058bf9d4aeb13b5ab11a56f72712ddc6a5457a3e9fcab9e3fbc1b4e30bca39b846b3969dc3e97e90bfd1f7be5ec8356de89faee00'
'4f881cc7ce83d8aa0c2ebd61faf49d0037389b83ec720de680f8c9a6feb9e2c53ab6f114de17a5be264117baf8a66e66185d22862f46f80d4647051ad37db388')