summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2024-05-13 14:55:32 +0200
committerPiotr Gorski2024-05-13 14:55:32 +0200
commitdbed0ca72f76b0111bf66986ecdc2b8a28816d2a (patch)
treee447a89937e9604d298708a66da0116dc889d18b /PKGBUILD
parentc467578e2f11aada28a18e6b31fece0a9e99b1d6 (diff)
downloadaur-dbed0ca72f76b0111bf66986ecdc2b8a28816d2a.tar.gz
Bump to 6.9-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 15 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbdb71fdfc15..da734b591086 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _cachy_config=${_cachy_config-y}
# ATTENTION - only one of the following values can be selected:
# 'bore' - select 'Burst-Oriented Response Enhancer'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
-# 'cachyos' - select 'EEVDF-BORE Variant Scheduler'
+# 'cachyos' - select 'Sched-Ext Scheduler Framework Variant Scheduler'
# 'eevdf' - select 'EEVDF Scheduler'
# 'rt' - select EEVDF, but includes a series of realtime patches
# 'rt-bore' - select Burst-Oriented Response Enhancer, but includes a series of realtime patches
@@ -82,20 +82,6 @@ _tickrate=${_tickrate-full}
## Choose between full(low-latency), voluntary or server
_preempt=${_preempt-full}
-### Enable multigenerational LRU
-# ATTENTION - one of three predefined values should be selected!
-# 'standard' - enable multigenerational LRU
-# 'stats' - enable multigenerational LRU with stats
-# 'none' - disable multigenerational LRU
-_lru_config=${_lru_config-standard}
-
-### Enable per-VMA locking
-# ATTENTION - one of three predefined values should be selected!
-# 'standard' - enable per-VMA locking
-# 'stats' - enable per-VMA locking with stats
-# 'none' - disable per-VMA locking
-_vma_config=${_vma_config-standard}
-
### Transparent Hugepages
# ATTENTION - one of two predefined values should be selected!
# 'always' - always enable THP
@@ -115,9 +101,9 @@ _damon=${_damon-}
# - "native_intel" (use compiler autodetection and will prompt for P6_NOPS - Selecting your arch manually in the list above is recommended instead of this option)
# - "generic" (kernel's default - to share the package between machines with different CPU µarch as long as they are x86-64)
#
-# Or use the _use_auto_optimization with _use_auto_optimization=y
_processor_opt=${_processor_opt-}
+# This does automatically detect your supported CPU and optimizes for it
_use_auto_optimization=${_use_auto_optimization-y}
# Clang LTO mode, only available with the "llvm" compiler - options are "none", "full" or "thin".
@@ -158,18 +144,18 @@ elif [ -n "$_use_llvm_lto" ] || [[ "$_use_lto_suffix" = "n" ]]; then
pkgsuffix=cachyos-${_cpusched}
pkgbase=linux-$pkgsuffix
fi
-_major=6.8
-_minor=9
+_major=6.9
+_minor=0
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
-_stable=${_major}.${_minor}
-#_stable=${_major}
+#_stable=${_major}.${_minor}
+_stable=${_major}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
-pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=4
+pkgdesc='Linux BORE + Cachy Sauce scheduler Kernel by CachyOS with other patches and improvements'
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -216,9 +202,8 @@ fi
## List of CachyOS schedulers
case "$_cpusched" in
- cachyos) ## SCHED-EXT + BORE Scheduler
- source+=("${_patchsource}/sched/0001-sched-ext.patch"
- "${_patchsource}/sched/0001-bore-cachy-ext.patch");;
+ cachyos) # CachyOS Scheduler (Sched-ext + Cachy Sauce)
+ source+=("${_patchsource}/sched/0001-sched-ext.patch");;
bore) ## BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
echo) ## ECHO Scheduler
@@ -289,7 +274,7 @@ prepare() {
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
case "$_cpusched" in
- cachyos) scripts/config -e SCHED_CLASS_EXT -e SCHED_BORE;;
+ cachyos) scripts/config -e SCHED_CLASS_EXT;;
bore|hardened) scripts/config -e SCHED_BORE;;
echo) scripts/config -e ECHO_SCHED;;
eevdf) ;;
@@ -422,29 +407,7 @@ prepare() {
--set-str DEFAULT_TCP_CONG bbr
fi
- ### Select LRU config
- [ -z "$_lru_config" ] && _die "The value is empty. Choose the correct one again."
-
- case "$_lru_config" in
- standard) scripts/config -e LRU_GEN -e LRU_GEN_ENABLED -d LRU_GEN_STATS;;
- stats) scripts/config -e LRU_GEN -e LRU_GEN_ENABLED -e LRU_GEN_STATS;;
- none) scripts/config -d LRU_GEN;;
- *) _die "The value '$_lru_config' is invalid. Choose the correct one again.";;
- esac
-
- echo "Selecting '$_lru_config' LRU_GEN config..."
-
- ### Select VMA config
- [ -z "$_vma_config" ] && _die "The value is empty. Choose the correct one again."
-
- case "$_vma_config" in
- standard) scripts/config -e PER_VMA_LOCK -d PER_VMA_LOCK_STATS;;
- stats) scripts/config -e PER_VMA_LOCK -e PER_VMA_LOCK_STATS;;
- none) scripts/config -d PER_VMA_LOCK;;
- *) _die "The value '$_vma_config' is invalid. Choose the correct one again.";;
- esac
- echo "Selecting '$_vma_config' PER_VMA_LOCK config..."
### Select THP
[ -z "$_hugepage" ] && _die "The value is empty. Choose the correct one again."
@@ -718,8 +681,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('0305b6636a4e382855a2804cedc3984f1e891b26b24412e3533b1f29a07459d39be5121d4618da20098623290e922d502b7ac1b774f39e732f23a778a4b5b5be'
- '68991dfe372201a6dad87e1f7d1f154708a35e8340f3ad37b490e51860badc3dda3d870b7cf5b30182d0e36a9e3585eaa307cb9a3d9577b9bbc09f58b9b09f23'
+b2sums=('4cf86c3cfe6e6534745d42dfaeca59b17ea1168c4e8b615c80e6d8aac735f11283cd85fa992b440b5d4452917e94b9f08397a64af0be5894e3df23c68892377e'
+ '541228216bba29398cdb391b88fed7e8a34c8f1192cf73fd07c90bc8bb06e537d935ea940261541322acf2c492479990cf7ff42f017c6e719ecf4e29284324ec'
'43ef7a347878592740d9eb23b40a56083fa747f7700fa1e2c6d039d660c0b876d99bf1a3160e15d041fb13d45906cdb5defef034d4d0ae429911864239c94d8d'
- 'cf12e295a43d5803a0a5f22e15e96e6e0cd7b7ed3cf34771f666d085abe2014f323ab876b7016afe59b42dee798f504569afbb175c08f24c4760f94956f5dd15'
- 'b768b9ceae2eb07964e4cde7a6894744a14eb6f5f2ebd68353035085020c1cdbc4151a8d28d6c70f27a780f31297589d00bf0fdf7faca00b436dfe631608419c')
+ '2a5d72807eb08aefee0e7ee35a617c1dc87a99b2f41857b8687dce0e106910b5bae07e2995784df9c14e37c63afb860f3f3a8b422ac29d83d3cdff87b176758e'
+ '4e57dfcf72b57fb049b6ff3b3b842704b0025df3f816ac9c01d6a6fc68e31813bcc400bbd6a713c5fdd939657e35fde074ef3234848f15c7e58651e46d285d7e')