summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2024-05-13 14:59:22 +0200
committerPiotr Gorski2024-05-13 14:59:22 +0200
commitfdbe1ee2235de42009165aabc6b9fab8df1df1ab (patch)
tree62fd898f5799b7b97e850a04c64d4b186c0df20d /PKGBUILD
parentdbed0ca72f76b0111bf66986ecdc2b8a28816d2a (diff)
downloadaur-fdbe1ee2235de42009165aabc6b9fab8df1df1ab.tar.gz
Bump to 6.9-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da734b591086..b2cd19f13791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _cachy_config=${_cachy_config-y}
# ATTENTION - only one of the following values can be selected:
# 'bore' - select 'Burst-Oriented Response Enhancer'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
-# 'cachyos' - select 'Sched-Ext Scheduler Framework Variant Scheduler'
+# 'cachyos' - select 'Sched-Ext Scheduler Framework Variant Scheduler with BORE Scheduler'
# 'eevdf' - select 'EEVDF Scheduler'
# 'rt' - select EEVDF, but includes a series of realtime patches
# 'rt-bore' - select Burst-Oriented Response Enhancer, but includes a series of realtime patches
@@ -202,8 +202,9 @@ fi
## List of CachyOS schedulers
case "$_cpusched" in
- cachyos) # CachyOS Scheduler (Sched-ext + Cachy Sauce)
- source+=("${_patchsource}/sched/0001-sched-ext.patch");;
+ cachyos) # CachyOS Scheduler (Sched-ext + BORE + Cachy Sauce)
+ source+=("${_patchsource}/sched/0001-sched-ext.patch"
+ "${_patchsource}/sched/0001-bore-cachy-ext.patch");;
bore) ## BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
echo) ## ECHO Scheduler
@@ -274,7 +275,7 @@ prepare() {
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
case "$_cpusched" in
- cachyos) scripts/config -e SCHED_CLASS_EXT;;
+ cachyos) scripts/config -e SCHED_CLASS_EXT -e SCHED_BORE;;
bore|hardened) scripts/config -e SCHED_BORE;;
echo) scripts/config -e ECHO_SCHED;;
eevdf) ;;