summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Jung2022-07-29 23:11:05 +0200
committerPeter Jung2022-07-29 23:11:05 +0200
commit3b7d7e2c136dcf3218d9605a30bd68ebf2e0e117 (patch)
treef794ee24052a0aed3be7de2a0f5c16653e90d8cf /PKGBUILD
parent858c5759ecde5799eb5c586930f7ebd6dd8b6eed (diff)
downloadaur-3b7d7e2c136dcf3218d9605a30bd68ebf2e0e117.tar.gz
5.18.15-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e48644aefddf..913408bb3060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
# 'cfs' - select 'Completely Fair Scheduler'
# 'tt' - select 'Task Type Scheduler by Hamad Marri'
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
-_cpusched='cacule'
+_cpusched='cfs'
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
@@ -132,7 +132,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=5.18
-_minor=14
+_minor=15
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -141,8 +141,8 @@ _stable=${_major}.${_minor}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
-pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgdesc='Linux CFS scheduler Kernel by CachyOS with other patches and improvements'
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -172,7 +172,7 @@ source=(
"${_patchsource}/all/0001-cachyos-base-all.patch"
)
if [ -n "$_build_zfs" ]; then
-source+=("git+https://github.com/openzfs/zfs.git#commit=6c3c5fcfbe27d9193cd131753cc7e47ee2784621")
+source+=("git+https://github.com/openzfs/zfs.git#commit=98315be03600dee78f5c844ed4ef422098493a24")
fi
if [ "$_cpusched" = "bmq" ]; then
source+=("${_patchsource}/sched/0001-prjc.patch")
@@ -223,6 +223,7 @@ prepare() {
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
+ # [[ $src = 0001-zfs-2.1.5-staging.patch ]] && continue
local src
for src in "${source[@]}"; do
src="${src%%::*}"
@@ -861,8 +862,7 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('e17d46451133d3a3099b09e200839e875100b48403171923ab71b6a9b39856af'
- 'a8f920b542bedb7aa1d04ac5d98f12fcec21d1f51c6ca9ee2196595223f12df8'
+sha256sums=('69804febdc388a69dfb64493b7b58d402853de3a14144ea8db7fd67c30dcbe3c'
+ '9b2cfc2cbf7015ec50d6f849fdf49c53a2d257d20a0988465759936db3aaf209'
'ce8bf7807b45a27eed05a5e1de5a0bf6293a3bbc2085bacae70cd1368f368d1f'
- 'b8582784394a098f9b30c48e92a411258109def73b0fdd042bc45c5441db6ba6'
- '767e142a3f0af19ee8a50287c453f34657fdf93451d5c94a4a8190b56715feb6')
+ '0b256630b9f79e776cf447a825dad88e5a6daf8693de35b2ff892e14b9212365')