summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2024-01-31 19:51:41 +0100
committerPiotr Gorski2024-01-31 19:51:41 +0100
commit01ca6802a30c5f3173026685d31d1ce23f60d0bf (patch)
tree2435d0403862bf30e764070fd465db87d7f5c557 /PKGBUILD
parent9544863c0ff60c295d8ad20ea6dc1dd69a4a2cc2 (diff)
downloadaur-01ca6802a30c5f3173026685d31d1ce23f60d0bf.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d78f6e626ef8..4dfcd20b14e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -174,7 +174,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux kernel with RT patches by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -224,9 +224,8 @@ fi
## List of CachyOS schedulers
case "$_cpusched" in
- cachyos) # CachyOS Scheduler (BORE + SCHED-EXT)
- source+=("${_patchsource}/sched/0001-sched-ext.patch"
- "${_patchsource}/sched/0001-bore-cachy.patch");;
+ cachyos|sched-ext) ## SCHED-EXT
+ source+=("${_patchsource}/sched/0001-sched-ext.patch");;
bore) ## BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
rt) ## EEVDF with RT patches
@@ -239,8 +238,6 @@ case "$_cpusched" in
hardened) ## Hardened Patches with BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch"
"${_patchsource}/misc/0001-hardened.patch");;
- sched-ext) ## SCHED-EXT
- source+=("${_patchsource}/sched/0001-sched-ext.patch");;
esac
## lrng patchset
@@ -299,12 +296,11 @@ prepare() {
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
case "$_cpusched" in
- cachyos) scripts/config -e SCHED_BORE -e SCHED_CLASS_EXT;;
+ cachyos|sched-ext) scripts/config -e SCHED_CLASS_EXT;;
bore|hardened) scripts/config -e SCHED_BORE;;
eevdf) ;;
rt) scripts/config -e PREEMPT_COUNT -e PREEMPTION -d PREEMPT_VOLUNTARY -d PREEMPT -d PREEMPT_NONE -e PREEMPT_RT -d PREEMPT_DYNAMIC -d PREEMPT_BUILD;;
rt-bore) scripts/config -e SCHED_BORE -e PREEMPT_COUNT -e PREEMPTION -d PREEMPT_VOLUNTARY -d PREEMPT -d PREEMPT_NONE -e PREEMPT_RT -d PREEMPT_DYNAMIC -d PREEMPT_BUILD;;
- sched-ext) scripts/config -e SCHED_CLASS_EXT;;
*) _die "The value $_cpusched is invalid. Choose the correct one again.";;
esac