summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2025-01-20 06:41:09 +0100
committerPiotr Gorski2025-01-20 06:41:09 +0100
commita6f901b8baa8d92fe4cb57c758aa256d8f8ecf60 (patch)
tree68cc352efc5e58f6758346aae9a619e7a47d44b3 /PKGBUILD
parent247c6621f3c8804c9c27e1faa3bd8acf26b3b659 (diff)
downloadaur-a6f901b8baa8d92fe4cb57c758aa256d8f8ecf60.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD133
1 files changed, 60 insertions, 73 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48cba8d52c8a..321bc7db403c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Set these variables to ANYTHING that is not null or choose proper variable to enable them
### Selecting CachyOS config
-_cachy_config=${_cachy_config-y}
+: "${_cachy_config:=yes}"
### Selecting the CPU scheduler
# ATTENTION - only one of the following values can be selected:
@@ -20,25 +20,25 @@ _cachy_config=${_cachy_config-y}
# 'eevdf' - select 'EEVDF Scheduler'
# 'rt' - select EEVDF, but includes a series of realtime patches
# 'rt-bore' - select Burst-Oriented Response Enhancer, but includes a series of realtime patches
-_cpusched=${_cpusched-bore}
+: "${_cpusched:=bore}"
### Tweak kernel options prior to a build via nconfig
-_makenconfig=${_makenconfig-}
+: "${_makenconfig:=no}"
### Tweak kernel options prior to a build via menuconfig
-_makemenuconfig=${_makemenuconfig-}
+: "${_makemenuconfig:=no}"
### Tweak kernel options prior to a build via xconfig
-_makexconfig=${_makexconfig-}
+: "${_makexconfig:=no}"
### Tweak kernel options prior to a build via gconfig
-_makegconfig=${_makegconfig-}
+: "${_makegconfig:=no}"
# NUMA is optimized for multi-socket motherboards.
# A single multi-core CPU actually runs slower with NUMA enabled.
# See, https://bugs.archlinux.org/task/31187
# It seems that in 2023 this is not really a huge regression anymore
-_NUMAdisable=${_NUMAdisable-}
+: "${_NUMAdisable:=no}"
# Compile ONLY used modules to VASTLYreduce the number of modules built
# and the build time.
@@ -48,36 +48,36 @@ _NUMAdisable=${_NUMAdisable-}
# This PKGBUILD read the database kept if it exists
#
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
-_localmodcfg=${_localmodcfg-}
+: "${_localmodcfg:=no}"
# Path to the list of used modules
-_localmodcfg_path=${_localmodcfg_path-"$HOME/.config/modprobed.db"}
+: "${_localmodcfg_path:="$HOME/.config/modprobed.db"}"
# Use the current kernel's .config file
# Enabling this option will use the .config of the RUNNING kernel rather than
# the ARCH defaults. Useful when the package gets updated and you already went
# through the trouble of customizing your config options. NOT recommended when
# a new kernel is released, but again, convenient for package bumps.
-_use_current=${_use_current-}
+: "${_use_current:=no}"
### Enable KBUILD_CFLAGS -O3
-_cc_harder=${_cc_harder-y}
+: "${_cc_harder:=yes}"
### Set performance governor as default
-_per_gov=${_per_gov-}
+: "${_per_gov:=no}"
### Enable TCP_CONG_BBR3
-_tcp_bbr3=${_tcp_bbr3-}
+: "${_tcp_bbr3:=no}"
### Running with a 1000HZ, 750Hz, 625Hz, 600 Hz, 500Hz, 300Hz, 250Hz and 100Hz tick rate
-_HZ_ticks=${_HZ_ticks-1000}
+: "${_HZ_ticks:=1000}"
## Choose between perodic, idle or full
### Full tickless can give higher performances in various cases but, depending on hardware, lower consistency.
-_tickrate=${_tickrate-full}
+: "${_tickrate:=full}"
## Choose between full(low-latency), voluntary or server
-_preempt=${_preempt-full}
+: "${_preempt:=full}"
### Transparent Hugepages
# ATTENTION - one of two predefined values should be selected!
@@ -85,7 +85,7 @@ _preempt=${_preempt-full}
# 'madvise' - madvise, prevent applications from allocating more memory resources than necessary
# More infos here:
# https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/performance_tuning_guide/sect-red_hat_enterprise_linux-performance_tuning_guide-configuring_transparent_huge_pages
-_hugepage=${_hugepage-always}
+: "${_hugepage:=always}"
# CPU compiler optimizations - Defaults to prompt at kernel config if left empty
# AMD CPUs : "k8" "k8sse3" "k10" "barcelona" "bobcat" "jaguar" "bulldozer" "piledriver" "steamroller" "excavator" "zen" "zen2" "zen3" "zen4"
@@ -95,52 +95,52 @@ _hugepage=${_hugepage-always}
# - "native_intel" (use compiler autodetection and will prompt for P6_NOPS - Selecting your arch manually in the list above is recommended instead of this option)
# - "generic" (kernel's default - to share the package between machines with different CPU µarch as long as they are x86-64)
#
-_processor_opt=${_processor_opt-}
+: "${_processor_opt:=}"
# This does automatically detect your supported CPU and optimizes for it
-_use_auto_optimization=${_use_auto_optimization-y}
+: "${_use_auto_optimization:=yes}"
# Clang LTO mode, only available with the "llvm" compiler - options are "none", "full" or "thin".
# ATTENTION - one of three predefined values should be selected!
# "full: uses 1 thread for Linking, slow and uses more memory, theoretically with the highest performance gains."
# "thin: uses multiple threads, faster and uses less memory, may have a lower runtime performance than Full."
# "none: disable LTO
-_use_llvm_lto=${_use_llvm_lto-none}
+: "${_use_llvm_lto:=none}"
# Use suffix -lto only when requested by the user
# Enabled by default.
-# y - enable -lto suffix
-# n - disable -lto suffix
+# yes - enable -lto suffix
+# no - disable -lto suffix
# https://github.com/CachyOS/linux-cachyos/issues/36
-_use_lto_suffix=${_use_lto_suffix-y}
+: "${_use_lto_suffix:=yes}"
# Use suffix -gcc when requested by the user
# This was added to facilitate https://github.com/CachyOS/linux-cachyos/issues/286
-_use_gcc_suffix=${_use_gcc_suffix-}
+: "${_use_gcc_suffix:=}"
# KCFI is a proposed forward-edge control-flow integrity scheme for
# Clang, which is more suitable for kernel use than the existing CFI
# scheme used by CONFIG_CFI_CLANG. kCFI doesn't require LTO, doesn't
# alter function references to point to a jump table, and won't break
# function address equality.
-_use_kcfi=${_use_kcfi-}
+: "${_use_kcfi:=no}"
# Build the zfs module in to the kernel
# WARNING: The ZFS module doesn't build with selected RT sched due to licensing issues.
# If you use ZFS, refrain from building the RT kernel
-_build_zfs=${_build_zfs-}
+: "${_build_zfs:=no}"
# Builds the nvidia module and package it into a own base
# This does replace the requirement of nvidia-dkms
-_build_nvidia=${_build_nvidia-}
+: "${_build_nvidia:=no}"
# Builds the open nvidia module and package it into a own base
# This does replace the requirement of nvidia-open-dkms
# Use this only if you have Turing+ GPU
-_build_nvidia_open=${_build_nvidia_open-}
+: "${_build_nvidia_open:=no}"
# Build a debug package with non-stripped vmlinux
-_build_debug=${_build_debug-}
+: "${_build_debug:=no}"
# ATTENTION: Do not modify after this line
_is_lto_kernel() {
@@ -148,9 +148,9 @@ _is_lto_kernel() {
return $?
}
-if _is_lto_kernel && [ "$_use_lto_suffix" = "y" ]; then
+if _is_lto_kernel && [ "$_use_lto_suffix" = "yes" ]; then
_pkgsuffix="cachyos-${_cpusched}-lto"
-elif ! _is_lto_kernel && [ "$_use_gcc_suffix" = "y" ]; then
+elif ! _is_lto_kernel && [ "$_use_gcc_suffix" = "yes" ]; then
_pkgsuffix="cachyos-${_cpusched}-gcc"
else
_pkgsuffix="cachyos-${_cpusched}"
@@ -158,7 +158,7 @@ fi
pkgbase="linux-$_pkgsuffix"
_major=6.12
-_minor=9
+_minor=10
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -216,18 +216,18 @@ if [[ "$_cpusched" = "rt" || "$_cpusched" = "rt-bore" ]]; then
fi
# ZFS support
-if [ -n "$_build_zfs" ]; then
+if [ "$_build_zfs" = "yes" ]; then
makedepends+=(git)
- source+=("git+https://github.com/cachyos/zfs.git#commit=e65f69e41f4a276d7d0d1800a2878308a0ba84a6")
+ source+=("git+https://github.com/cachyos/zfs.git#commit=76745cf5b86540f80e8e5faea85f8685a1b76caa")
fi
# NVIDIA pre-build module support
-if [ -n "$_build_nvidia" ]; then
+if [ "$_build_nvidia" = "yes" ]; then
source+=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${_nv_ver}/${_nv_pkg}.run"
"${_patchsource}/misc/nvidia/0001-Make-modeset-and-fbdev-default-enabled.patch")
fi
-if [ -n "$_build_nvidia_open" ]; then
+if [ "$_build_nvidia_open" = "yes" ]; then
source+=("nvidia-open-${_nv_ver}.tar.gz::https://github.com/NVIDIA/open-gpu-kernel-modules/archive/refs/tags/${_nv_ver}.tar.gz"
"${_patchsource}/misc/nvidia/0001-Make-modeset-and-fbdev-default-enabled.patch"
"${_patchsource}/misc/nvidia/0002-Do-not-error-on-unkown-CPU-Type-and-add-Zen5-support.patch"
@@ -294,19 +294,17 @@ prepare() {
fi
### Use autooptimization
- if [ -n "$_use_auto_optimization" ]; then
+ if [ "$_use_auto_optimization" = "yes" ]; then
"${srcdir}"/auto-cpu-optimization.sh
fi
### Selecting CachyOS config
- if [ -n "$_cachy_config" ]; then
+ if [ "$_cachy_config" = "yes" ]; then
echo "Enabling CachyOS config..."
scripts/config -e CACHY
fi
### Selecting the CPU scheduler
- [ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
-
case "$_cpusched" in
cachyos|bore|hardened) scripts/config -e SCHED_BORE;;
bmq) scripts/config -e SCHED_ALT -e SCHED_BMQ;;
@@ -319,14 +317,12 @@ prepare() {
echo "Selecting ${_cpusched^^} CPU scheduler..."
### Enable KCFI
- if [ -n "$_use_kcfi" ]; then
+ if [ "$_use_kcfi" = "yes" ]; then
echo "Enabling kCFI"
scripts/config -e ARCH_SUPPORTS_CFI_CLANG -e CFI_CLANG -e CFI_AUTO_DEFAULT
fi
### Select LLVM level
- [ -z "$_use_llvm_lto" ] && _die "The value is empty. Choose the correct one again."
-
case "$_use_llvm_lto" in
thin) scripts/config -e LTO -e LTO_CLANG -e ARCH_SUPPORTS_LTO_CLANG -e ARCH_SUPPORTS_LTO_CLANG_THIN -d LTO_NONE -e HAS_LTO_CLANG -d LTO_CLANG_FULL -e LTO_CLANG_THIN -e HAVE_GCC_PLUGINS;;
full) scripts/config -e LTO -e LTO_CLANG -e ARCH_SUPPORTS_LTO_CLANG -e ARCH_SUPPORTS_LTO_CLANG_THIN -d LTO_NONE -e HAS_LTO_CLANG -e LTO_CLANG_FULL -d LTO_CLANG_THIN -e HAVE_GCC_PLUGINS;;
@@ -337,8 +333,6 @@ prepare() {
echo "Selecting '$_use_llvm_lto' LLVM level..."
### Select tick rate
- [ -z "$_HZ_ticks" ] && _die "The value is empty. Choose the correct one again."
-
case "$_HZ_ticks" in
100|250|500|600|625|750|1000)
scripts/config -d HZ_300 -e "HZ_${_HZ_ticks}" --set-val HZ "${_HZ_ticks}";;
@@ -351,7 +345,7 @@ prepare() {
echo "Setting tick rate to ${_HZ_ticks}Hz..."
### Disable NUMA
- if [ -n "$_NUMAdisable" ]; then
+ if [ "$_NUMAdisable" = "yes" ]; then
echo "Disabling NUMA from kernel config..."
scripts/config -d NUMA \
-d AMD_NUMA \
@@ -369,15 +363,13 @@ prepare() {
fi
### Select performance governor
- if [ -n "$_per_gov" ]; then
+ if [ "$_per_gov" = "yes" ]; then
echo "Setting performance governor..."
scripts/config -d CPU_FREQ_DEFAULT_GOV_SCHEDUTIL \
-e CPU_FREQ_DEFAULT_GOV_PERFORMANCE
fi
### Select tick type
- [ -z "$_tickrate" ] && _die "The value is empty. Choose the correct one again."
-
case "$_tickrate" in
perodic) scripts/config -d NO_HZ_IDLE -d NO_HZ_FULL -d NO_HZ -d NO_HZ_COMMON -e HZ_PERIODIC;;
idle) scripts/config -d HZ_PERIODIC -d NO_HZ_FULL -e NO_HZ_IDLE -e NO_HZ -e NO_HZ_COMMON;;
@@ -391,8 +383,6 @@ prepare() {
# We should not set up the PREEMPT for RT kernels
if [[ "$_cpusched" != "rt" || "$_cpusched" != "rt-bore" ]]; then
- [ -z "$_preempt" ] && _die "The value is empty. Choose the correct one again."
-
case "$_preempt" in
full) scripts/config -e PREEMPT_BUILD -d PREEMPT_NONE -d PREEMPT_VOLUNTARY -e PREEMPT -e PREEMPT_COUNT -e PREEMPTION -e PREEMPT_DYNAMIC;;
voluntary) scripts/config -e PREEMPT_BUILD -d PREEMPT_NONE -e PREEMPT_VOLUNTARY -d PREEMPT -e PREEMPT_COUNT -e PREEMPTION -d PREEMPT_DYNAMIC;;
@@ -404,7 +394,7 @@ prepare() {
fi
### Enable O3
- if [ -n "$_cc_harder" ] && [ -z "$_cc_size" ]; then
+ if [ "$_cc_harder" = "yes" ]; then
echo "Enabling KBUILD_CFLAGS -O3..."
scripts/config -d CC_OPTIMIZE_FOR_PERFORMANCE \
-e CC_OPTIMIZE_FOR_PERFORMANCE_O3
@@ -427,7 +417,7 @@ prepare() {
fi
### Enable bbr3
- if [ -n "$_tcp_bbr3" ]; then
+ if [ "$_tcp_bbr3" = "yes" ]; then
echo "Disabling TCP_CONG_CUBIC..."
scripts/config -m TCP_CONG_CUBIC \
-d DEFAULT_CUBIC \
@@ -441,8 +431,6 @@ prepare() {
fi
### Select THP
- [ -z "$_hugepage" ] && _die "The value is empty. Choose the correct one again."
-
case "$_hugepage" in
always) scripts/config -d TRANSPARENT_HUGEPAGE_MADVISE -e TRANSPARENT_HUGEPAGE_ALWAYS;;
madvise) scripts/config -d TRANSPARENT_HUGEPAGE_ALWAYS -e TRANSPARENT_HUGEPAGE_MADVISE;;
@@ -456,7 +444,7 @@ prepare() {
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
- if [ -n "$_use_current" ]; then
+ if [ "$_use_current" = "yes" ]; then
if [[ -s /proc/config.gz ]]; then
echo "Extracting config from /proc/config.gz..."
# modprobe configs
@@ -469,10 +457,9 @@ prepare() {
fi
fi
-
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "$_localmodcfg" ]; then
+ if [ "$_localmodcfg" = "yes" ]; then
if [ -e "$_localmodcfg_path" ]; then
echo "Running Steven Rostedt's make localmodconfig now"
make "${BUILD_FLAGS[@]}" LSMOD="${_localmodcfg_path}" localmodconfig
@@ -492,23 +479,23 @@ prepare() {
echo "Prepared $pkgbase version $(<version)"
### Running make nconfig
- [[ -z "$_makenconfig" ]] || make "${BUILD_FLAGS[@]}" nconfig
+ [ "$_makenconfig" = "yes" ] && make "${BUILD_FLAGS[@]}" nconfig
### Running make menuconfig
- [[ -z "$_makemenuconfig" ]] || make "${BUILD_FLAGS[@]}" menuconfig
+ [ "$_makemenuconfig" = "yes" ] && make "${BUILD_FLAGS[@]}" menuconfig
### Running make xconfig
- [[ -z "$_makexconfig" ]] || make "${BUILD_FLAGS[@]}" xconfig
+ [ "$_makexconfig" = "yes" ] && make "${BUILD_FLAGS[@]}" xconfig
### Running make gconfig
- [[ -z "$_makegconfig" ]] || make "${BUILD_FLAGS[@]}" gconfig
+ [ "$_makegconfig" = "yes" ] && make "${BUILD_FLAGS[@]}" gconfig
### Save configuration for later reuse
echo "Save configuration for later reuse..."
local basedir="$(dirname "$(readlink "${srcdir}/config")")"
cat .config > "${basedir}/config-${pkgver}-${pkgrel}${pkgbase#linux}"
- if [ -n "$_build_nvidia" ]; then
+ if [ "$_build_nvidia" = "yes" ]; then
cd "${srcdir}"
sh "${_nv_pkg}.run" --extract-only
@@ -516,7 +503,7 @@ prepare() {
patch -Np1 -i "${srcdir}/0001-Make-modeset-and-fbdev-default-enabled.patch" -d "${srcdir}/${_nv_pkg}/kernel"
fi
- if [ -n "$_build_nvidia_open" ]; then
+ if [ "$_build_nvidia_open" = "yes" ]; then
patch -Np1 -i "${srcdir}/0001-Make-modeset-and-fbdev-default-enabled.patch" -d "${srcdir}/${_nv_open_pkg}/kernel-open"
# Fix for Zen5 error print in dmesg
patch -Np1 --no-backup-if-mismatch -i "${srcdir}/0002-Do-not-error-on-unkown-CPU-Type-and-add-Zen5-support.patch" -d "${srcdir}/${_nv_open_pkg}"
@@ -540,20 +527,20 @@ build() {
SYSSRC="${srcdir}/${_srcname}"
SYSOUT="${srcdir}/${_srcname}"
)
- if [ -n "$_build_nvidia" ]; then
+ if [ "$_build_nvidia" = "yes" ]; then
MODULE_FLAGS+=(NV_EXCLUDE_BUILD_MODULES='__EXCLUDE_MODULES')
cd "${srcdir}/${_nv_pkg}/kernel"
make "${BUILD_FLAGS[@]}" "${MODULE_FLAGS[@]}" -j"$(nproc)" modules
fi
- if [ -n "$_build_nvidia_open" ]; then
+ if [ "$_build_nvidia_open" = "yes" ]; then
cd "${srcdir}/${_nv_open_pkg}"
MODULE_FLAGS+=(IGNORE_CC_MISMATCH=yes)
CFLAGS= CXXFLAGS= LDFLAGS= make "${BUILD_FLAGS[@]}" "${MODULE_FLAGS[@]}" -j"$(nproc)" modules
fi
- if [ -n "$_build_zfs" ]; then
+ if [ "$_build_zfs" = "yes" ]; then
cd ${srcdir}/"zfs"
local CONFIGURE_FLAGS=()
@@ -745,11 +732,11 @@ _package-nvidia-open(){
}
pkgname=("$pkgbase")
-[ -n "$_build_debug" ] && pkgname+=("$pkgbase-dbg")
+[ "$_build_debug" = "yes" ] && pkgname+=("$pkgbase-dbg")
pkgname+=("$pkgbase-headers")
-[ -n "$_build_zfs" ] && pkgname+=("$pkgbase-zfs")
-[ -n "$_build_nvidia" ] && pkgname+=("$pkgbase-nvidia")
-[ -n "$_build_nvidia_open" ] && pkgname+=("$pkgbase-nvidia-open")
+[ "$_build_zfs" = "yes" ] && pkgname+=("$pkgbase-zfs")
+[ "$_build_nvidia" = "yes" ] && pkgname+=("$pkgbase-nvidia")
+[ "$_build_nvidia_open" = "yes" ] && pkgname+=("$pkgbase-nvidia-open")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
@@ -757,8 +744,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('2584e35822a429b6825bf8d99c073848d5ba83d45b382ab82d1caa36ccbf2529036b31d4687dafb29650c87f4b63489caa2cb67a85d05183c572dcad75a35ba8'
+b2sums=('3146bbc9075b84db4c6ad3a64cbb91e3c379d0b8e9e90029eaf6a5bd37ea2b8a0a4ac1227e73d0e8acd20cab392841e046e148523bdb206302ea6c37a934b451'
'a2747236876de1e02c7bde58be26b18656e619c8271402827c2e62df694d32798fb02f2217590a16ea9ab310fb602331913a5e109534a5ce2afc76603a3fc144'
'390c7b80608e9017f752b18660cc18ad1ec69f0aab41a2edfcfc26621dcccf5c7051c9d233d9bdf1df63d5f1589549ee0ba3a30e43148509d27dafa9102c19ab'
- 'cc197827aeca2961121f3235fd690db3e0ffde1d3abe2fda02ff21f7e31165e6e565969634565f8605eccaf269fc3741bf9d7004c566edd5d310592e6a89568c'
+ 'edfafc06fd1e93f5e4c1b341dc978eae439440ea584e53b4d81600461f2e189656e9dcaff61209ba4b093455c955a84f436e136160687b0d23bfbed433e15bfd'
'b8007db21488fcd281dde293aba0dfc7afcf556e19d6f397ea7e017e4254b6c3c97e96be9680868d2c03c3500d7b4cdc6493b2896d819d9cf7debf5ebf2ea964')