summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Jung2022-03-26 10:33:09 +0000
committerPeter Jung2022-03-26 10:33:09 +0000
commit147a383c8e7c73a43c67b73517f5b064f4fbd7fc (patch)
treeb53f805cd386103f1100d44f3a77ef43059cc81c /PKGBUILD
parent7e88470476f422e0aad7ecea30506f5e6d07a1fe (diff)
downloadaur-147a383c8e7c73a43c67b73517f5b064f4fbd7fc.tar.gz
5.17.0-5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 26 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1e1a487dacb..e5a47c3304da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ _makenconfig=
# NUMA is optimized for multi-socket motherboards.
# A single multi-core CPU actually runs slower with NUMA enabled.
# See, https://bugs.archlinux.org/task/31187
-_NUMAdisable=
+_NUMAdisable=y
# Compile ONLY used modules to VASTLYreduce the number of modules built
# and the build time.
@@ -65,13 +65,13 @@ _mq_deadline_disable=y
_kyber_disable=y
### Enable protect file mappings under memory pressure
-_mm_protect=y
+_mm_protect=
### Enable multigenerational LRU
_lru_enable=y
### Enable DAMON
-_damon=
+_damon=y
### Enable Linux Random Number Generator
_lrng_enable=y
@@ -133,7 +133,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_major}
arch=(x86_64 x86_64_v3)
pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=5
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
license=('GPL2')
@@ -146,32 +146,30 @@ _patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.
source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
"config"
- # "${_patchsource}/sched/0001-pjrc.patch"
+ # "${_patchsource}/sched/0001-prjc.patch"
"${_patchsource}/sched/0001-cacULE.patch"
- # "${_patchsource}/sched/0001-bore-sched.patch"
+ # "${_patchsource}/sched/0001-bore-sched.patch"
# "${_patchsource}/sched/0001-tt.patch"
- "${_patchsource}/0001-cachy.patch"
"${_patchsource}/0001-anbox.patch"
"${_patchsource}/0001-bbr2.patch"
+ "${_patchsource}/0001-block-patches.patch"
+ "${_patchsource}/0001-btrfs-patches.patch"
+ "${_patchsource}/0001-cachy.patch"
"${_patchsource}/0001-cfi.patch"
- "${_patchsource}/0001-kbuild.patch"
- "${_patchsource}/0001-lrng.patch"
- "${_patchsource}/0001-fast-headers.patch"
- "${_patchsource}/0001-cpu.patch"
"${_patchsource}/0001-clr.patch"
+ "${_patchsource}/0001-cpu.patch"
+ "${_patchsource}/0001-cpupower-patches.patch"
+ "${_patchsource}/0001-fixes-miscellaneous.patch"
+ "${_patchsource}/0001-lrng.patch"
"${_patchsource}/0001-pf-patches.patch"
"${_patchsource}/0001-hwmon.patch"
"${_patchsource}/0001-MG-LRU.patch"
- "${_patchsource}/0001-ksm.patch"
- "${_patchsource}/0001-zstd-patches.patch"
"${_patchsource}/0001-v4l2loopback.patch"
+ "${_patchsource}/0001-xanmod.patch"
# "${_patchsource}/0001-zen-patches.patch"
# "${_patchsource}/0001-FG-KASLR.patch"
"auto-cpu-optimization.sh"
)
-#if [ -n "$_use_pgo" ]; then
-# source+=("${_patchsource}/0001-PGO.patch")
-#fi
if [ -n "$_use_llvm_lto" ]; then
BUILD_FLAGS=(
@@ -231,6 +229,7 @@ prepare() {
echo "Selecting CacULE scheduler..."
scripts/config --disable CONFIG_SCHED_ALT
scripts/config --enable CONFIG_CACULE_SCHED
+ script/config --disable CONFIG_CACULE_RDB
elif [ "$_cpusched" = "cacule-rdb" ]; then
echo "Selecting CacULE-RDB scheduler..."
scripts/config --disable CONFIG_SCHED_ALT
@@ -678,21 +677,22 @@ for _p in "${pkgname[@]}"; do
done
sha256sums=('555fef61dddb591a83d62dd04e252792f9af4ba9ef14683f64840e46fa20b1b1'
- 'a97a365b633338b87a869f86a0ae315fa39c672ca0303e7425e430f6b3bbbada'
- '727baab0da8792920a015073dc554987fa237e0183aa49c013568ee2b3d38b35'
- 'cbd65e8ed6949034d15d42288579a2e32576bda34eb32a83cc8c47244ca0e032'
+ '12528c68981695b4b72c6c605f0a5405f032f24540467f164d5816ffee657542'
+ '33c0d70410ac7e0fccce5796aacea76838b048c79bbdc92eaf2fdbb5eabd4e0d'
'b81d81435984662cc5948e5e26389402d6803ceb4cd3fe346f632fdf4c81f9ed'
'ec150c2d74c58de56ab230679fe4c27b63a8bb4180f57e1985ff7fe7dced0401'
+ '863d3627ef5eb474840a5847ee0b479a80e2521261b8ca3e0f71fcfb78a392b4'
+ '1ea4823c2f0f9fc42f943703f146fa68b2c94f05aef6e284ec4d1fea56dd0572'
+ '2ccacea819390dfa67251b0c211804bcc03a079a9970fd6e147bb09248e75b6f'
'fbc98ae990ef1f75ac5a11eb822e01503b5cc09b412f3b3d2e03adde04123068'
- 'c8cc9414b0f63f088942db5b1051e28a3e097313631fc0762138a0ec1f849613'
- '3439e178798812c2f6d72b2e6e596b7869f4bf9b1e6fce4688359fc6ef0303d9'
- '9baa40f901f2b8a9630377c2955a998afa3758bea2ebca3f26ca32ee2b57bbd5'
- 'd8be9d58186b09cd6d8ac0633889e9483f88c59702579b26d45d0a42a906de8f'
'8ea353787ab41f9d2566cc166d763b1cd4aa33a302df7f0f39c1a3a69aaa56e6'
- '83cf18b9f0aaea76b828258d6fd040eacc416d52cb6cbb5d2cb52257f0fb0b4c'
+ 'd8be9d58186b09cd6d8ac0633889e9483f88c59702579b26d45d0a42a906de8f'
+ 'c92373359de38b4ac831ab69f57c6bb962a14d214beba55593616c9077003aff'
+ '6d392c1ac65810c5a532f107536919e8675436b34cea421c0a6052d28cf9c84e'
+ '3439e178798812c2f6d72b2e6e596b7869f4bf9b1e6fce4688359fc6ef0303d9'
+ '0ee3af3d964de63c0f90fe4622b0b1ccfd240e547e797f3a4be8c1b1c0b0ea98'
'9675c0ab1914bc9d31b520089bd40e8d5f311f6d481e737f7f3f6e122e7c4eb4'
'ba9c6058daafa76dfe8585da638da6434d2f7ce65b54623a002b6581a0ad553a'
- 'b230bab0efeddd7044d820a4109982d636d07ff07866123eb430535573143e30'
- '98bcd7467b0ac9c6f2db4b38c590bf6db7f6dbd58e66e56459efcb31329cb213'
'8490dd7d0b9f6731187e682e90e77fbd191533de339a008a8d5009046ef4f822'
+ '66c4c8935a995f552fa612ad8d039149559144c2ea5b54f873d7eebebd5c18f6'
'65ec9ac5b8b28d5b61df1c72498059be2e7cb1f9b965bac0e4ffed3c05520b2b')