summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-11-17 22:38:43 +0100
committerPiotr Gorski2022-11-17 22:38:43 +0100
commit3da42b1ec92f78aaca228aa5a845a562c0a9f634 (patch)
treea4d8d166efd29a5c88a1938a65cbb484e58a6eb7 /PKGBUILD
parent947c43337df80aa9af500241b2d10344aa69c62d (diff)
downloadaur-3da42b1ec92f78aaca228aa5a845a562c0a9f634.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 2 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dafc706ad94..25bedfd1bdf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -97,13 +97,6 @@ _kyber_disable=${_kyber_disable-y}
# 'none' - disable multigenerational LRU
_lru_config=${_lru_config-'standard'}
-### Enable per-VMA locking
-# ATTENTION - one of three predefined values should be selected!
-# 'standard' - enable per-VMA locking
-# 'stats' - enable per-VMA locking with stats
-# 'none' - disable per-VMA locking
-_vma_config=${_vma_config-'standard'}
-
## Enable DAMON
_damon=${_damon-}
@@ -654,28 +647,6 @@ prepare() {
exit
fi
- ### Select VMA config
- if [ "$_vma_config" = "standard" ]; then
- echo "Enabling per-VMA locking..."
- scripts/config --enable PER_VMA_LOCK \
- --disable PER_VMA_LOCK_STATS
- elif [ "$_vma_config" = "stats" ]; then
- echo "Enabling per-VMA locking with stats..."
- scripts/config --enable PER_VMA_LOCK \
- --enable PER_VMA_LOCK_STATS
- elif [ "$_vma_config" = "none" ]; then
- echo "Disabling per-VMA locking..."
- scripts/config --disable PER_VMA_LOCK
- else
- if [ -n "$_vma_config" ]; then
- error "The value $_vma_config is invalid. Choose the correct one again."
- else
- error "The value is empty. Choose the correct one again."
- fi
- error "Enabling per-VMA locking failed!"
- exit
- fi
-
### Enable DAMON
if [ -n "$_damon" ]; then
echo "Enabling DAMON..."
@@ -994,7 +965,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -1038,7 +1009,7 @@ done
sha256sums=('6114a208e82739b4a1ab059ace35262be2a83be34cd1ae23cb8a09337db831c7'
'cf045c82aceef20747a25fe27e464b4728e5dbc24f9abfbf0ae541b810c06744'
- '34e2cad286f32d8c1c26e4ff18726c9e0aee151e82088bb78c3ae4fb536bf962'
+ 'c3aae004fe02ddf781037bf95ca9994692d19eda2b6b99d5cd767ae23edfb2a5'
'e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e'
'a0734e8dc037d4faae845f7f1c837ba1dbf304c786c1fcd4ff317a2959d64006'
'2b9f45f0cc8e7c4871cd75e0932b03f2a0c633db9a875af1f308d4f4976d0948')