summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-28 01:23:59 +0200
committerPiotr Gorski2022-09-28 01:23:59 +0200
commit46bf935e97bc029af811709d49d29f2b75b13717 (patch)
tree416104fcb446d49a9c1ea814ebb57f6c50930bb6 /PKGBUILD
parenteb4440340f07b7825095e0e6cab6fca2011eacb6 (diff)
downloadaur-46bf935e97bc029af811709d49d29f2b75b13717.tar.gz
Improve nest and latency nice flags
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d79cac3f1a4a..8295229dd07c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -272,11 +272,15 @@ if [ -n "$_bcachefs" ]; then
fi
## NEST Support
if [ -n "$_nest" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/sched/0001-NEST.patch")
+ fi
fi
## Latency NICE Support
if [ -n "$_latency_nice" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+ fi
fi
export KBUILD_BUILD_HOST=cachyos