summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-12-31 17:03:39 +0100
committerPiotr Gorski2022-12-31 17:03:39 +0100
commit52f5de21db0271b5f5afee7e6918a5af6ae1f1da (patch)
tree507e3491cadd55d569548050df753d886c081f61 /PKGBUILD
parent192888fb9c3285da3a9eaff2bed9c69c66878f81 (diff)
downloadaur-52f5de21db0271b5f5afee7e6918a5af6ae1f1da.tar.gz
Bump to 6.1.2
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 62 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e56f84889b9d..bfb507eda256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -97,6 +97,21 @@ _kyber_disable=${_kyber_disable-y}
# 'none' - disable multigenerational LRU
_lru_config=${_lru_config-'standard'}
+### Enable per-VMA locking
+# ATTENTION - one of three predefined values should be selected!
+# 'standard' - enable per-VMA locking
+# 'stats' - enable per-VMA locking with stats
+# 'none' - disable per-VMA locking
+_vma_config=${_vma_config-'standard'}
+
+### Transparent Hugepages
+# ATTENTION - one of two predefined values should be selected!
+# 'always' - always enable THP
+# 'madvise' - madvise, prevent applications from allocating more memory resources than necessary
+# More infos here:
+# https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/performance_tuning_guide/sect-red_hat_enterprise_linux-performance_tuning_guide-configuring_transparent_huge_pages
+_hugepage=${_hugepage-'always'}
+
## Enable DAMON
_damon=${_damon-}
@@ -185,7 +200,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.1
-_minor=1
+_minor=2
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -276,7 +291,7 @@ if [ -n "$_use_kcfi" ]; then
fi
## bcachefs Support
if [ -n "$_bcachefs" ]; then
- source+=("${_patchsource}/misc/0001-bcachefs-after-lru.patch")
+ source+=("${_patchsource}/misc/0001-bcachefs.patch")
fi
if [ -n "$_use_gcc_lto" ]; then
## GCC-LTO Patch
@@ -492,7 +507,7 @@ prepare() {
scripts/config --set-val NR_CPUS "$_nr_cpus"
else
echo "Setting default NR_CPUS..."
- scripts/config --set-val NR_CPUS 128
+ scripts/config --set-val NR_CPUS 320
fi
### Disable MQ Deadline I/O scheduler
@@ -628,6 +643,47 @@ prepare() {
exit
fi
+ ### Select VMA config
+ if [ "$_vma_config" = "standard" ]; then
+ echo "Enabling per-VMA locking..."
+ scripts/config --enable PER_VMA_LOCK \
+ --disable PER_VMA_LOCK_STATS
+ elif [ "$_vma_config" = "stats" ]; then
+ echo "Enabling per-VMA locking with stats..."
+ scripts/config --enable PER_VMA_LOCK \
+ --enable PER_VMA_LOCK_STATS
+ elif [ "$_vma_config" = "none" ]; then
+ echo "Disabling per-VMA locking..."
+ scripts/config --disable PER_VMA_LOCK
+ else
+ if [ -n "$_vma_config" ]; then
+ error "The value $_vma_config is invalid. Choose the correct one again."
+ else
+ error "The value is empty. Choose the correct one again."
+ fi
+ error "Enabling per-VMA locking failed!"
+ exit
+ fi
+
+ ### Select THP
+ if [ "$_hugepage" = "always" ]; then
+ echo "Enable THP always..."
+ scripts/config --disable TRANSPARENT_HUGEPAGE_MADVISE \
+ --enable TRANSPARENT_HUGEPAGE_ALWAYS
+ elif [ "$_hugepage" = "madvise" ]; then
+ echo "Enable THP madvise..."
+ scripts/config --disable TRANSPARENT_HUGEPAGE_ALWAYS \
+ --enable TRANSPARENT_HUGEPAGE_MADVISE
+ else
+ if [ -n "$_hugepage" ]; then
+ error "The value $_hugepage is invalid. Choose the correct one again."
+ else
+ error "The value is empty. Choose the correct one again."
+ fi
+ error "Setting THP has failed!"
+ exit
+ fi
+
### Enable DAMON
if [ -n "$_damon" ]; then
echo "Enabling DAMON..."
@@ -988,8 +1044,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('a3e61377cf4435a9e2966b409a37a1056f6aaa59e561add9125a88e3c0971dfb'
- 'c9c662d6adbf5a4bfeee3cabab6eafe7b9a2d2d51532df2bd53df1c61b6d5260'
+sha256sums=('ee41f3c4f599b2f46f08aae428c9243db403e7292eb2c9f04ee34909b038d1ae'
+ 'd4f3fc2581e338835a33983cca18bfb3225450a07c456c48c9b051c03236955a'
'32e77b3b71225c9f04df2d44c25f982773a8fff9927d26788366baab5e242e74'
- '4f0aac3acf834b5fbe933ae0e133d27db23063c4ae4317c8d21e64fa624a47b5'
+ '1ec422b623d99bcac518075d498e2a32f91151a532edb4ba51b993667b6c32a5'
'48afb08df95035b315bb882c03d7b66d320bccf54977822050a5c3cd7acd2709')