summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2015-10-27 17:11:44 -0400
committergraysky2015-10-27 17:11:44 -0400
commit2f91acf16a97f62d5eacac2f05a232418f4bb5d4 (patch)
tree425d8abbceeb7e785cc44d9ef0123767de77f0e1 /PKGBUILD
parent59cf95ed37ff9147265c1ed576e7fa8a53f05675 (diff)
downloadaur-2f91acf16a97f62d5eacac2f05a232418f4bb5d4.tar.gz
Update to 4.1.12-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0e377b5550b..a10a57dd4691 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,7 @@ _localmodcfg=
# a new kernel is released, but again, convenient for package bumps.
_use_current=
-# Alternative I/O scheduler by Paolo.
+# Alternative I/O scheduler by Paolo Valente
# Set this if you want it enabled globally i.e. for all devices in your system
# If you want it enabled on a device-by-device basis, leave this unset and see:
# https://wiki.archlinux.org/index.php/Linux-ck#How_to_Enable_the_BFQ_I.2FO_Scheduler
@@ -52,7 +52,7 @@ _BFQ_enable_=
pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.1
-pkgver=4.1.11
+pkgver=4.1.12
pkgrel=1
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
@@ -72,6 +72,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'change-default-console-loglevel.patch'
# ck1
"http://ck.kolivas.org/patches/4.0/4.1/4.1-ck${_ckpatchversion}/${_ckpatchname}.bz2"
+'bfs-009-add-preempt_offset-argument-to-should_resched.patch'
# gcc
"http://repo-ck.com/source/gcc_patch/${_gcc_patch}.gz"
# bfq
@@ -80,13 +81,14 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"${_bfqpath}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r8-for-4.1.0.patch")
sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
'SKIP'
- 'f98156dd7ceac2849de16b38cdb7a530cd3c74833ab613e0822b7bc4583cccb1'
+ 'f3520b06e6a2b9929173c680de75f11cde9f0a380e04195d538b5de820a549ae'
'SKIP'
'b04ce2128ddb94be5ffafb4383d5c8b016760500696b1426a6e552c9a61ab27c'
'cc181fe0cfcedcd3bf606d7cce53e07dfb206d6c3549238dc7f4d0d27973d1a4'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'87726411f583862e456156fe82ef51b188e5d92e7a4bd944e01a091cd7c46428'
+ '0c8d94a0c416db0fafe6f12469798b2ea9f3d23d9cd712b6db7e1eaf421097e0'
'819961379909c028e321f37e27a8b1b08f1f1e3dd58680e07b541921282da532'
'ec0ca3c8051ea6d9a27a450998af8162464c224299deefc29044172940e96975'
'c5c2c48638c2a8180948bd118ffcc33c8b7ff5f9f1e4b04c8e2cafeca2bde87b'
@@ -113,6 +115,10 @@ prepare() {
msg "Patching source with ck2 including BFS v0.464"
patch -Np1 -i "${srcdir}/${_ckpatchname}"
+ # build issue fix for 4.1.12
+ # http://ck-hack.blogspot.com/2015/08/bfs-464-linux-41-ck2.html?showComment=1445937376359#c8153343895524903784
+ patch -Np1 -i "${srcdir}/bfs-009-add-preempt_offset-argument-to-should_resched.patch"
+
# Patch source to enable more gcc CPU optimizatons via the make nconfig
msg "Patching source with gcc patch to enable more cpus types"
patch -Np1 -i "${srcdir}/${_gcc_patch}"