summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2019-11-01 14:02:04 -0400
committergraysky2019-11-01 14:02:04 -0400
commitc62aaad9f19e6035079b1cdcaa50860078d4512f (patch)
tree450026fee5edb2e1361f51304c19654c2fe05e6f /PKGBUILD
parent7d51a31be407e9e9a5bc021301096606515cdad1 (diff)
downloadaur-c62aaad9f19e6035079b1cdcaa50860078d4512f.tar.gz
Update to 5.3.8-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 2 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4186947523b2..22adfde2a947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,5 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Tobias Powalowski <tpowa@archlinux.org>
-# Contributor: Thomas Baechler <thomas@archlinux.org>
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
@@ -65,7 +63,7 @@ _localmodcfg=
pkgbase=linux-ck
_srcver=5.3.8-arch1
pkgver=${_srcver%-*}
-pkgrel=1
+pkgrel=2
_ckpatchversion=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
@@ -77,9 +75,6 @@ _gcc_more_v='20190822'
source=(
"https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
config # the main kernel config file
- 60-linux.hook # pacman hook for depmod
- 90-linux.hook # pacman hook for initramfs regeneration
- linux.preset # standard config files for mkinitcpio ramdisk
"enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
"http://ck.kolivas.org/patches/5.0/5.3/5.3-ck${_ckpatchversion}/$_ckpatch.xz"
fix.systemd-detect-virt.patch::https://github.com/ckolivas/linux/commit/6e346c7b4258ac03ec308741e8e28e0da3abf911.patch
@@ -93,18 +88,12 @@ validpgpkeys=(
sha256sums=('78f3cfc6c20b10ff21c0bb22d7d257cab03781c44d8c5aae289f749f94f76649'
'SKIP'
'e6d2df92f3079c740ca2cafd7e8b34b5dd43832d292284c2dc133d47600d1f29'
- '452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c'
- 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
- 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
'5b66761eae4efa4cb967aba9d4e555aa320cf5c004f0848e6bfbcb75ef66fbf1'
'01367272cd82cafc24ae04d309d5c738352949727dc2a37f8578c14c7a90b9f0'
'cb38c0468a9ee0507e97e48be4a51116c1db952b7599906f2c36933b03e1ca34'
'4b4d388e0cb6b2448d644463e4693bb08122716117aafa411ce78305da305642')
-_kernelname=${pkgbase#linux}
-: ${_kernelname:=-ARCH}
-
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="@${SOURCE_DATE_EPOCH:-$(date +%s)}"
@@ -200,14 +189,13 @@ _package() {
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
provides=("linux-ck=${pkgver}")
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
- install=linux.install
#groups=('ck-generic')
cd linux-${pkgver}
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
@@ -227,25 +215,6 @@ _package() {
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Installing hooks..."
- # sed expression for following substitutions
- local subst="
- s|%PKGBASE%|$pkgbase|g
- s|%KERNVER%|$kernver|g
- "
-
- # hack to allow specifying an initially nonexisting install file
- sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
- true && install=$install.pkg
-
- # fill in mkinitcpio preset and pacman hooks
- sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
- "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
- sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
- sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
-
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}