summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2017-08-12 10:32:35 -0400
committergraysky2017-08-12 10:32:35 -0400
commite41e0014c8ef341b78b50b4a90213e962df41aa2 (patch)
treeeed69042e22935772194fc3a3c2651fc50186ea0 /PKGBUILD
parent2d3a52d7d6291c1fbc622003000808d28d403fbd (diff)
downloadaur-e41e0014c8ef341b78b50b4a90213e962df41aa2.tar.gz
Update to 4.12.6-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 626421092243..8bcd0c12fa48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,22 +44,22 @@ _use_current=
### Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-_srcname=linux-4.11
-pkgver=4.11.12
+_srcname=linux-4.12
+pkgver=4.12.6
pkgrel=1
-_ckpatchversion=2
+_ckpatchversion=1
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
-_ckpatchname="patch-4.11-ck${_ckpatchversion}"
+_ckpatchname="patch-4.12-ck${_ckpatchversion}"
_gcc_patch='enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch'
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- "http://ck.kolivas.org/patches/4.0/4.11/4.11-ck${_ckpatchversion}/${_ckpatchname}.xz"
+ "http://ck.kolivas.org/patches/4.0/4.12/4.12-ck${_ckpatchversion}/${_ckpatchname}.xz"
"http://repo-ck.com/source/gcc_patch/${_gcc_patch}.gz"
# the main kernel config files
'config.i686' 'config.x86_64'
@@ -68,14 +68,14 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
)
-sha256sums=('b67ecafd0a42b3383bf4d82f0850cbff92a7e72a215a6d02f42ddbafcf42a7d6'
+sha256sums=('a45c3becd4d08ce411c14628a949d08e2433d8cdeca92036c7013980e93858ab'
'SKIP'
- '707c5f18dfb795761b0b7ac6f946f03774f9f99317306fd54d8724d17d9c7729'
+ '60938af0f95ae794f879294f2393c48077c01bdba851e80b085fdc0418eeca44'
'SKIP'
- '1acde415a6a35d301beb65bc09bd20903f3a9c835c6c850f4c5a0ce0ab236bc1'
+ 'c20ca8b06355fd923a6b942d573e74118fd2abbc8a5ea282d994967122a04a2d'
'0f3e4930c3a603cc99fffa9fcac0f2cf7c58fc14a7ef8557345358c0bcd2bf66'
- '86bd514df01899f47863f703515efd33b488307a8f823a6c9a2c16607ec41187'
- '5d4d0122fa8eace141564e27861bcdb3a5ef65010df3cd9ca1c6d8ff3b3d3dad'
+ 'df55887a43dcbb6bd35fd2fb1ec841427b6ea827334c0880cbc256d4f042a7a1'
+ '6897f728f13d3f3f18cde837cfa71e231107487b3989af8d80cf73df04fc6ce0'
'834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
validpgpkeys=(
@@ -190,8 +190,8 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck2 patchset featuring MuQSS CPU scheduler v0.156"
- #_Kpkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck2 patchset featuring MuQSS CPU scheduler v0.156"
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler v0.157"
+ #_Kpkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler v0.157"
#pkgdesc="${_Kpkgdesc}"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')