summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorantman6662021-05-29 21:39:39 +0800
committerantman6662021-05-29 21:39:39 +0800
commit4c8b89046357b21ae4066a4f4c7f0c0d6568b401 (patch)
tree781b78c08a5e6a656ca848e6d4877a8e8bb5c407 /PKGBUILD
downloadaur-4c8b89046357b21ae4066a4f4c7f0c0d6568b401.tar.gz
update linux-ck1-uksm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD328
1 files changed, 328 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4366dd884e51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,328 @@
+# Maintainer: antman666 <945360554@qq.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: graysky <graysky AT archlinux DOT us>
+
+### BUILD OPTIONS
+# Set the next two variables to ANYTHING that is not null to enable them
+
+# Tweak kernel options prior to a build via nconfig
+_makenconfig=
+
+# Only compile active modules to VASTLY reduce the number of modules built and
+# the build time.
+#
+# To keep track of which modules are needed for your specific system/hardware,
+# give module_db a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD reads the database kept if it exists
+#
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
+_localmodcfg=
+
+# Optionally select a sub architecture by number or leave blank which will
+# require user interaction during the build. Note that the generic (default)
+# option is 36.
+#
+# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
+# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3) (NEW)
+# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10) (NEW)
+# 4. AMD Barcelona (MBARCELONA) (NEW)
+# 5. AMD Bobcat (MBOBCAT) (NEW)
+# 6. AMD Jaguar (MJAGUAR) (NEW)
+# 7. AMD Bulldozer (MBULLDOZER) (NEW)
+# 8. AMD Piledriver (MPILEDRIVER) (NEW)
+# 9. AMD Steamroller (MSTEAMROLLER) (NEW)
+# 10. AMD Excavator (MEXCAVATOR) (NEW)
+# 11. AMD Zen (MZEN) (NEW)
+# 12. AMD Zen 2 (MZEN2) (NEW)
+# 13. AMD Zen 3 (MZEN3) (NEW)
+# 14. Intel P4 / older Netburst based Xeon (MPSC)
+# 15. Intel Core 2 (MCORE2)
+# 16. Intel Atom (MATOM)
+# 17. Intel Nehalem (MNEHALEM) (NEW)
+# 18. Intel Westmere (MWESTMERE) (NEW)
+# 19. Intel Silvermont (MSILVERMONT) (NEW)
+# 20. Intel Goldmont (MGOLDMONT) (NEW)
+# 21. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
+# 22. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
+# 23. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
+# 24. Intel Haswell (MHASWELL) (NEW)
+# 25. Intel Broadwell (MBROADWELL) (NEW)
+# 26. Intel Skylake (MSKYLAKE) (NEW)
+# 27. Intel Skylake X (MSKYLAKEX) (NEW)
+# 28. Intel Cannon Lake (MCANNONLAKE) (NEW)
+# 29. Intel Ice Lake (MICELAKE) (NEW)
+# 30. Intel Cascade Lake (MCASCADELAKE) (NEW)
+# 31. Intel Cooper Lake (MCOOPERLAKE) (NEW)
+# 32. Intel Tiger Lake (MTIGERLAKE) (NEW)
+# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
+# 34. Intel Rocket Lake (MROCKETLAKE) (NEW)
+# 35. Intel Alder Lake (MALDERLAKE) (NEW)
+# 36. Generic-x86-64 (GENERIC_CPU)
+# 37. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
+# 38. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
+# 39. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
+# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL) (NEW)
+# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD) (NEW)
+_subarch=
+
+### IMPORTANT: Do no edit below this line unless you know what you're doing
+
+pkgbase=linux-ck-uksm
+pkgver=5.12.8
+pkgrel=1
+_ckpatchversion=1
+_major=5.12
+arch=(x86_64)
+url="https://wiki.archlinux.org/index.php/Linux-ck"
+license=(GPL2)
+makedepends=(
+ bc kmod libelf cpio perl tar xz
+)
+options=('!strip')
+_ckpatch="patch-5.12-ck${_ckpatchversion}"
+_gcc_more_v=20210412
+source=(
+ "https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
+ config # the main kernel config file
+ "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
+ "http://ck.kolivas.org/patches/5.0/5.12/5.12-ck${_ckpatchversion}/$_ckpatch.xz"
+ 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ 0002-UKSM.patch
+)
+validpgpkeys=(
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+)
+b2sums=('c2d0c2239c5b440cc93e1e0e312511497eccf9e5cef61707c7f42fa924f66defdd4275575341b46b3ee45269c705dd2ba2e2c68fb1dd4ced438b852803180ddb'
+ 'SKIP'
+ 'SKIP'
+ '72194a32a06c43809d1272bd675890b6d27c6c54353150a366e8e2c50ad6eca6ee23c5d6281822965a228cfedfa07a60fe135d1b4f539e4a62728d4460cc0b0e'
+ 'c9f729ba1efe6f04e7b2c57d3999bc9675b577596dccb2f227e5b6e444285e1fdd270bf67c0fcf9f5808a4c3a4b1c7a5c13a76f754ad9b9447243ccbaf2ce6a3'
+ 'e1eccb5b6b728e3852ade55dae7a53b8b6bd5f0fb2a330b99e85bfa64abaa430cb714d301ed169df14a1f302a75d952992f0d8fa6ab02fa6716165bdf23b63aa'
+ '62147c71b76b9986b60df333267882f089c89997cef430c8864e521536d76a6d7679733cbbea163c31341a48ad589c11b98231f71aafe0eaf87f0a3a84add429')
+
+export KBUILD_BUILD_HOST=archlinux
+export KBUILD_BUILD_USER=$pkgbase
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
+
+prepare() {
+ cd linux-${pkgver}
+
+ echo "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux}" > localversion.20-pkgname
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = 0*.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+
+ echo "Setting config..."
+ cp ../config .config
+
+ # disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
+ # and can easily overwhelm a system with 32 GB of memory using a tmpfs build
+ # partition ... this was introduced by FS#66260, see:
+ # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
+ scripts/config --disable CONFIG_DEBUG_INFO
+ scripts/config --disable CONFIG_CGROUP_BPF
+ scripts/config --disable CONFIG_BPF_LSM
+ scripts/config --disable CONFIG_BPF_PRELOAD
+ scripts/config --disable CONFIG_BPF_LIRC_MODE2
+ scripts/config --disable CONFIG_BPF_KPROBE_OVERRIDE
+
+ # https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
+ scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
+
+ # https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
+ scripts/config --disable CONFIG_LATENCYTOP
+ scripts/config --disable CONFIG_SCHED_DEBUG
+
+ # FS#66613
+ # https://bugzilla.kernel.org/show_bug.cgi?id=207173#c6
+ scripts/config --disable CONFIG_KVM_WERROR
+
+ # fix naming schema in EXTRAVERSION of ck patch set
+ sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatch}"
+
+ # ck patchset itself
+ echo "Patching with ck patchset..."
+ patch -Np1 -i ../"${_ckpatch}"
+
+ # non-interactively apply ck1 default options
+ # this isn't redundant if we want a clean selection of subarch below
+ make olddefconfig
+
+ # https://github.com/graysky2/kernel_gcc_patch
+ # make sure to apply after olddefconfig to allow the next section
+ echo "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/more-uarches-for-kernel-5.8+.patch"
+
+ if [ -n "$_subarch" ]; then
+ # user wants a subarch so apply choice defined above interactively via 'yes'
+ yes "$_subarch" | make oldconfig
+ else
+ # no subarch defined so allow user to pick one
+ make oldconfig
+ fi
+
+ ### Optionally load needed modules for the make localmodconfig
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -f $HOME/.config/modprobed.db ]; then
+ echo "Running Steven Rostedt's make localmodconfig now"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ echo "No modprobed.db data found"
+ exit
+ fi
+ fi
+
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
+
+ [[ -z "$_makenconfig" ]] || make nconfig
+
+ # save configuration for later reuse
+ cat .config > "${startdir}/config.last"
+
+ # uncomment if you want to build with distcc
+ ### sed -i '/HAVE_GCC_PLUGINS/d' arch/x86/Kconfig
+}
+
+build() {
+ cd linux-${pkgver}
+ make all
+}
+
+_package() {
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 and uksm patchset featuring MuQSS CPU scheduler"
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ #groups=('ck-generic')
+
+ cd linux-${pkgver}
+
+ local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+
+ echo "Installing boot image..."
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ #install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ #
+ # hard-coded path in case user defined CC=xxx for build which causes errors
+ # see this FS https://bugs.archlinux.org/task/64315
+ install -Dm644 arch/x86/boot/bzImage "$modulesdir/vmlinuz"
+
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
+ echo "Installing modules..."
+ #make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ # not needed since not building with CONFIG_DEBUG_INFO=y
+
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+
+ # remove build and source links
+ rm "$modulesdir"/{source,build}
+}
+
+_package-headers() {
+ pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ depends=("$pkgbase") # added to keep kernel and headers packages matched
+ #groups=('ck-generic')
+
+ cd linux-${pkgver}
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ echo "Installing build files..."
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
+ install -Dt "$builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$builddir" -a scripts
+
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+
+ # add xfs and shmem for aufs building
+ mkdir -p "$builddir"/{fs/xfs,mm}
+
+ echo "Installing headers..."
+ cp -t "$builddir" -a include
+ cp -t "$builddir/arch/x86" -a arch/x86/include
+ install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+
+ install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+
+ # http://bugs.archlinux.org/task/13146
+ install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+
+ # http://bugs.archlinux.org/task/20402
+ install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+
+ echo "Installing KConfig files..."
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+
+ echo "Removing unneeded architectures..."
+ local arch
+ for arch in "$builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
+ echo "Removing $(basename "$arch")"
+ rm -r "$arch"
+ done
+
+ echo "Removing documentation..."
+ rm -r "$builddir/Documentation"
+
+ echo "Removing broken symlinks..."
+ find -L "$builddir" -type l -printf 'Removing %P\n' -delete
+
+ echo "Removing loose objects..."
+ find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+
+ echo "Stripping build tools..."
+ local file
+ while read -rd '' file; do
+ case "$(file -bi "$file")" in
+ application/x-sharedlib\;*) # Libraries (.so)
+ strip -v $STRIP_SHARED "$file" ;;
+ application/x-archive\;*) # Libraries (.a)
+ strip -v $STRIP_STATIC "$file" ;;
+ application/x-executable\;*) # Binaries
+ strip -v $STRIP_BINARIES "$file" ;;
+ application/x-pie-executable\;*) # Relocatable binaries
+ strip -v $STRIP_SHARED "$file" ;;
+ esac
+ done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
+ #echo "Stripping vmlinux..."
+ #strip -v $STRIP_STATIC "$builddir/vmlinux"
+ # not needed since not building with CONFIG_DEBUG_INFO=y
+
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
+
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers")
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+done
+
+# vim:set ts=8 sts=2 sw=2 et: