summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2022-03-31 17:18:40 +0200
committerJosip Ponjavic2022-03-31 17:18:40 +0200
commit04515bcf6cc940c47970d3bdcb95278f56d94037 (patch)
tree234dd95dd200404b97ef21fe4598daf03d87d6b0 /PKGBUILD
parenta6e7f48a23f281614492991287c3199a3ff3c7ba (diff)
downloadaur-04515bcf6cc940c47970d3bdcb95278f56d94037.tar.gz
5.16.18-2 (clr 5.16.18-1137) improve _debug option
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f214f83c491..3d8de4f5a592 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -74,7 +74,9 @@
# Enable compiling with LLVM
: "${_use_llvm_lto:=""}"
-# Enable debug options
+# Enable/Disable debug options
+# Set 'y' to enable, 'n' to force disable debug options if already enabled in your
+# .config file or leave empty to ignore debug options.
: "${_debug:=""}"
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -82,10 +84,10 @@
_major=5.16
_minor=18
_srcname=linux-${_major}
-_clr=${_major}.17-1136
+_clr=${_major}.18-1137
pkgbase=linux-clear
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
pkgdesc='Clear Linux'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
@@ -149,8 +151,8 @@ prepare() {
echo "Setting config..."
cp -Tf $srcdir/$pkgbase/config ./.config
- ### Enable extra stuff from arch kernel
- echo "Enable extra stuff from arch kernel..."
+ ### Enable extra options
+ echo "Enable extra options..."
# General setup
scripts/config --set-str DEFAULT_HOSTNAME archlinux \
@@ -228,12 +230,18 @@ prepare() {
--enable HAVE_GCC_PLUGINS
fi
- if [ -n "$_debug" ]; then
+ if [ "$_debug" == "y" ]; then
scripts/config --enable DEBUG_INFO \
--enable DEBUG_INFO_BTF \
--enable DEBUG_INFO_DWARF4 \
--enable PAHOLE_HAS_SPLIT_BTF \
--enable DEBUG_INFO_BTF_MODULES
+ elif [ "$_debug" == "n" ]; then
+ scripts/config --disable DEBUG_INFO \
+ --disable DEBUG_INFO_BTF \
+ --disable DEBUG_INFO_DWARF4 \
+ --disable PAHOLE_HAS_SPLIT_BTF \
+ --disable DEBUG_INFO_BTF_MODULES
fi
make ${BUILD_FLAGS[*]} olddefconfig
@@ -340,7 +348,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- if [ -n "$_debug" ]; then
+ if [ -f tools/bpf/resolve_btfids/resolve_btfids ]; then
install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
fi