summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2020-05-29 12:40:02 +0200
committerJosip Ponjavic2020-05-29 12:40:02 +0200
commit404bad3dd33c08389cd65633a863fed384034bc6 (patch)
tree39462b24530a771f63d5f9023f22886ca2506e0c /PKGBUILD
parentf94765b46aa6da15a642e702d7115d3050de2001 (diff)
downloadaur-404bad3dd33c08389cd65633a863fed384034bc6.tar.gz
5.6.15-2 (clr 5.6.15-956)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c30f249feaca..1e54d626fa08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _enable_gcc_more_v="y"
# Optionally select a sub architecture by number if building in a clean chroot
# Leaving this entry blank will require user interaction during the build
# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 30.
+# generic (default) option is 32.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -42,9 +42,11 @@ _enable_gcc_more_v="y"
# 27. Intel Cannon Lake (MCANNONLAKE)
# 28. Intel Ice Lake (MICELAKE)
# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Generic-x86-64 (GENERIC_CPU)
-# 31. Native optimizations autodetected by GCC (MNATIVE)
-_subarch=31
+# 30. Intel Cooper Lake (MCOOPERLAKE)
+# 31. Intel Tiger Lake (MTIGERLAKE)
+# 32. Generic-x86-64 (GENERIC_CPU)
+# 33. Native optimizations autodetected by GCC (MNATIVE)
+_subarch=33
# Compile ONLY used modules to VASTLY reduce the number of modules built
# and the build time.
@@ -68,22 +70,23 @@ _use_current=
_major=5.6
_minor=15
_srcname=linux-${_major}
-_clr=${_major}.14-955
+_clr=${_major}.15-956
pkgbase=linux-clear
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
pkgdesc='Clear Linux'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
options=('!strip')
+_gcc_more_v='20200527'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.xz"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.sign"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=${_clr}"
- 'enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.4-5.6_v1.patch'
+ "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
'pci-enable-overrides-for-missing-acs-capabilities.patch'
'0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch'
)
@@ -155,6 +158,9 @@ prepare() {
--module-after SND_MIXER_OSS SND_PCM_OSS \
--enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
+ # Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
+ scripts/config --enable SECTION_MISMATCH_WARN_ONLY
+
# Security options
scripts/config --enable SECURITY_SELINUX \
--enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \
@@ -174,8 +180,8 @@ prepare() {
### Patch source to unlock additional gcc CPU optimizations
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
- echo "Applying enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.4-5.6_v1.patch ..."
- patch -Np1 -i "$srcdir/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.4-5.6_v1.patch"
+ echo "Applying enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.5-v5.6.patch ..."
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.5-v5.6.patch"
fi
### Get kernel version
@@ -349,7 +355,7 @@ sha256sums=('e342b04a2aa63808ea0ef1baab28fc520bd031ef8cf93d9ee4a31d4058fcb622'
'SKIP'
'995f3a824d7ee90b137fc22af9b5e2b7d0b1f9f81b51bfb01bfc284bf9109e34'
'SKIP'
- 'c650fc6ff773e99dbc1fda9411b10b06513c5161791106c44d5a11dbcf6420f9'
+ '8255e6b6e0bdcd66a73d917b56cf2cccdd1c3f4b3621891cfffc203404a5b6dc'
'2c98de0814366b041aeee4cbf82b82620c7834bc33752d50f089e8bd7ea5cf5e'
'bdd05caf94135898bceac0a9d14ec6b1b458dba162d00efd46a292fe97f2679b')