summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2018-11-22 21:58:32 +0100
committerJosip Ponjavic2018-11-22 21:58:32 +0100
commit43c4ca5fb08014c4a625c8751076d1013aaf3a4b (patch)
treebbe96b42cf4bfd016dcf83acecae7bc17610877c /PKGBUILD
parent19bdcfd7ecbe0d6b92d239e773061d511ccb9578 (diff)
downloadaur-43c4ca5fb08014c4a625c8751076d1013aaf3a4b.tar.gz
4.19.3-2 (clr 4.19.2-662) Add vmlinuz symlink for systemd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a433fa6517cd..88bfc8707d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,13 +63,13 @@ _rev_override="n"
### IMPORTANT: Do no edit below this line unless you know what you're doing
-pkgbase=linux-clear
_major=4.19
_minor=3
-pkgver=${_major}.${_minor}
_srcname=linux-${_major}
-pkgrel=1
_clr=${_major}.2-662
+pkgbase=linux-clear
+pkgver=${_major}.${_minor}
+pkgrel=2
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
@@ -201,13 +201,18 @@ _package() {
cd ${_srcname}
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"