summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2022-04-11 10:21:03 +0200
committerJosip Ponjavic2022-04-11 10:21:03 +0200
commit485800ea7fe0d53ba2ec32d476d3fc7a0906ca54 (patch)
tree88bf7dbc14b0392a08ae712dc41f8e123f762eef /PKGBUILD
parentaa69636f2a5cfb798c9b2ecb4a7ce702fc970c98 (diff)
downloadaur-485800ea7fe0d53ba2ec32d476d3fc7a0906ca54.tar.gz
sync with arch: FS#72275: Don't package files created by depmod
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e2f2a40a291..15a183a00b20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -92,7 +92,7 @@ pkgdesc='Clear Linux'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
-makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'pahole' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'libelf' 'pahole' 'xmlto')
if [ -n "$_use_llvm_lto" ]; then
makedepends+=(clang llvm lld python)
fi
@@ -324,7 +324,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}