summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2023-05-12 13:46:14 +0200
committerJosip Ponjavic2023-05-12 13:46:14 +0200
commit81920786b266a8422ef06d5a6a0166a4b2559a19 (patch)
tree1e0ec745ca3c3362780ee0c590f19c5fb5b4b6a8 /PKGBUILD
parentf792a292d20564ab638cb78e373224eb5ab9dd86 (diff)
downloadaur-81920786b266a8422ef06d5a6a0166a4b2559a19.tar.gz
6.3.2-1 (clr 6.3.2-1312)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 36 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d29ba166aa97..8d776cb399d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
# Optionally select a sub architecture by number or leave blank which will
# require user interaction during the build. Note that the generic (default)
-# option is 36.
+# option is 40.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -34,34 +34,38 @@
# 11. AMD Zen (MZEN)
# 12. AMD Zen 2 (MZEN2)
# 13. AMD Zen 3 (MZEN3)
-# 14. Intel P4 / older Netburst based Xeon (MPSC)
-# 15. Intel Core 2 (MCORE2)
-# 16. Intel Atom (MATOM)
-# 17. Intel Nehalem (MNEHALEM)
-# 18. Intel Westmere (MWESTMERE)
-# 19. Intel Silvermont (MSILVERMONT)
-# 20. Intel Goldmont (MGOLDMONT)
-# 21. Intel Goldmont Plus (MGOLDMONTPLUS)
-# 22. Intel Sandy Bridge (MSANDYBRIDGE)
-# 23. Intel Ivy Bridge (MIVYBRIDGE)
-# 24. Intel Haswell (MHASWELL)
-# 25. Intel Broadwell (MBROADWELL)
-# 26. Intel Skylake (MSKYLAKE)
-# 27. Intel Skylake X (MSKYLAKEX)
-# 28. Intel Cannon Lake (MCANNONLAKE)
-# 29. Intel Ice Lake (MICELAKE)
-# 30. Intel Cascade Lake (MCASCADELAKE)
-# 31. Intel Cooper Lake (MCOOPERLAKE)
-# 32. Intel Tiger Lake (MTIGERLAKE)
-# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS)
-# 34. Intel Rocket Lake (MROCKETLAKE)
-# 35. Intel Alder Lake (MALDERLAKE)
-# 36. Generic-x86-64 (GENERIC_CPU)
-# 37. Generic-x86-64-v2 (GENERIC_CPU2)
-# 38. Generic-x86-64-v3 (GENERIC_CPU3)
-# 39. Generic-x86-64-v4 (GENERIC_CPU4)
-# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL)
-# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD)
+# 14. AMD Zen 4 (MZEN4)
+# 15. Intel P4 / older Netburst based Xeon (MPSC)
+# 16. Intel Core 2 (MCORE2)
+# 17. Intel Atom (MATOM)
+# 18. Intel Nehalem (MNEHALEM)
+# 19. Intel Westmere (MWESTMERE)
+# 20. Intel Silvermont (MSILVERMONT)
+# 21. Intel Goldmont (MGOLDMONT)
+# 22. Intel Goldmont Plus (MGOLDMONTPLUS)
+# 23. Intel Sandy Bridge (MSANDYBRIDGE)
+# 24. Intel Ivy Bridge (MIVYBRIDGE)
+# 25. Intel Haswell (MHASWELL)
+# 26. Intel Broadwell (MBROADWELL)
+# 27. Intel Skylake (MSKYLAKE)
+# 28. Intel Skylake X (MSKYLAKEX)
+# 29. Intel Cannon Lake (MCANNONLAKE)
+# 30. Intel Ice Lake (MICELAKE)
+# 31. Intel Cascade Lake (MCASCADELAKE)
+# 32. Intel Cooper Lake (MCOOPERLAKE)
+# 33. Intel Tiger Lake (MTIGERLAKE)
+# 34. Intel Sapphire Rapids (MSAPPHIRERAPIDS)
+# 35. Intel Rocket Lake (MROCKETLAKE)
+# 36. Intel Alder Lake (MALDERLAKE)
+# 37. Intel Raptor Lake (MRAPTORLAKE)
+# 38. Intel Meteor Lake (MMETEORLAKE)
+# 39. Intel Emerald Rapids (MEMERALDRAPIDS)
+# 40. Generic-x86-64 (GENERIC_CPU)
+# 41. Generic-x86-64-v2 (GENERIC_CPU2)
+# 42. Generic-x86-64-v3 (GENERIC_CPU3)
+# 43. Generic-x86-64-v4 (GENERIC_CPU4)
+# 44. Intel-Native optimizations autodetected by the compiler (MNATIVE_INTEL)
+# 45. AMD-Native optimizations autodetected by the compiler (MNATIVE_AMD)
: "${_subarch:=""}"
# Use the current kernel's .config file
@@ -82,9 +86,9 @@
### IMPORTANT: Do no edit below this line unless you know what you're doing
_major=6.3
-_minor=1
+_minor=2
_srcname=linux-${_major}
-_clr=${_major}.1-1311
+_clr=${_major}.2-1312
_gcc_more_v='20230105'
pkgbase=linux-clear
pkgver=${_major}.${_minor}
@@ -417,7 +421,7 @@ done
sha256sums=('ba3491f5ed6bd270a370c440434e3d69085fcdd528922fa01e73d7657db73b1e'
'SKIP'
- '49216a8d1d09f2e291b56a0e7cb4ea9bce0869719c7823011b3626e80f22f322'
+ '3b7ee32bef5e522d137893131e61395f99b4edcc34aa146059685cf94a1e12c9'
'SKIP'
'802946f623c69ae1a636b63697c23ca48af31a099415ed837d2c1e168a272d23')