summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2018-12-03 13:16:27 +0100
committerJosip Ponjavic2018-12-03 13:16:27 +0100
commitc1219d83a070dacff0500f77ece0556ed38986ad (patch)
tree6a01e0f0b2f04c14f77768986838ffa468571891 /PKGBUILD
parentfc35ca45efa883007372060f5f9d126b1bff699f (diff)
downloadaur-c1219d83a070dacff0500f77ece0556ed38986ad.tar.gz
4.19.6-2 (clr 4.19.6-666)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e560107397e..574b2c63b7ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,9 +47,7 @@ _subarch=27
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
-# begin making the pkg unless you're running modprobed-db (AUR) and building
-# this with makepkg as the user who is keeping the database.
+# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -68,10 +66,10 @@ _rev_override="n"
_major=4.19
_minor=6
_srcname=linux-${_major}
-_clr=${_major}.5-665
+_clr=${_major}.6-666
pkgbase=linux-clear
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
@@ -164,11 +162,12 @@ CONFIG_MODULE_COMPRESS_XZ=y|' ./.config
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ msg2 "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ -x /usr/bin/sudo ]] || {
+ echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
+ exit 1; }
+ sudo /usr/bin/modprobed-db recall
make localmodconfig
fi
fi