summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2019-10-05 13:32:44 +0200
committerJosip Ponjavic2019-10-05 13:32:44 +0200
commitcfa957941f740c8286ba93292297d8f4f06f948b (patch)
tree8e2859c20ada655c4de61a35d10435ee290c2119 /PKGBUILD
parent24960148b099988d558e1bcf81e4c3fca8e5300d (diff)
downloadaur-cfa957941f740c8286ba93292297d8f4f06f948b.tar.gz
Sync with Arch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f17d76bc5e02..f4ec85be2a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -186,8 +186,10 @@ build() {
_package() {
pkgdesc="Clearlinux kernel and modules"
- depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
provides=('WIREGUARD-MODULE')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux.install
@@ -203,6 +205,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install