summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2020-02-17 20:26:40 +0100
committerJosip Ponjavic2020-02-17 20:26:40 +0100
commit05bdf4912871ee96503d36231fc710f62308eb01 (patch)
tree81f6442a69d7fa4e50ef8c968e8c364b858aabdd /PKGBUILD
parent5cdd304fa39de05715b2544a05b10aeb831f31c6 (diff)
downloadaur-05bdf4912871ee96503d36231fc710f62308eb01.tar.gz
5.6.0.rc2-1 (clr 5.6.0.rc1-12)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD80
1 files changed, 36 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c040f028207..14b80ee75d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,24 +58,23 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
-_major=5.3
-_minor=11
-_srcname=linux-${_major}
-_clr=${_major}.1-11
+_major=5.6
+_minor=0
+_rc=2
+_srcname=linux-${_major}-rc${_rc}
+_clr=${_major}.0.rc1-12
pkgbase=linux-clear-current
-pkgver=${_major}.${_minor}
+pkgver=${_major}.${_minor}.rc${_rc}
pkgrel=1
pkgdesc='Clear Linux current'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-current"
license=('GPL2')
-makedepends=('bc' 'cpio' 'git' 'inetutils' 'kmod' 'libelf' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
options=('!strip')
-_gcc_more_v='20190822'
+_gcc_more_v='20191217'
source=(
- "https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.xz"
- "https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.sign"
- "https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
+ "https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
"clearlinux-current::git+https://github.com/clearlinux-pkgs/linux-current.git#tag=${_clr}"
"enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
)
@@ -87,37 +86,32 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd ${_srcname}
- ### Add upstream patches
- msg2 "Add upstream patches"
- patch -Np1 -i ../patch-${pkgver}
-
### Setting version
- msg2 "Setting version..."
+ echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
### Add Clearlinux patches
for i in $(grep '^Patch' ${srcdir}/clearlinux-current/linux-current.spec | grep -Ev '^Patch0123' | sed -n 's/.*: //p'); do
- msg2 "Applying patch ${i}..."
+ echo "Applying patch ${i}..."
patch -Np1 -i "$srcdir/clearlinux-current/${i}"
done
### Setting config
- msg2 "Setting config..."
+ echo "Setting config..."
cp -Tf $srcdir/clearlinux-current/config ./.config
### Enable extra stuff from arch kernel
- msg2 "Enable extra stuff from arch kernel..."
+ echo "Enable extra stuff from arch kernel..."
# General setup
- scripts/config --module IKCONFIG \
+ scripts/config --enable IKCONFIG \
--enable-after IKCONFIG IKCONFIG_PROC \
--undefine RT_GROUP_SCHED
# Power management and ACPI options
- scripts/config --enable HIBERNATION \
- --enable ACPI_REV_OVERRIDE_POSSIBLE \
+ scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
--enable ACPI_TABLE_UPGRADE
# Enable loadable module support
@@ -155,8 +149,8 @@ prepare() {
### Patch source to unlock additional gcc CPU optimizations
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
- msg2 "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
+ echo "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v5.5+.patch ..."
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v5.5+.patch"
fi
### Get kernel version
@@ -168,16 +162,16 @@ prepare() {
### Prepared version
make -s kernelrelease > version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
+ echo "Prepared $pkgbase version $(<version)"
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ echo "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
else
- msg2 "No modprobed.db data found"
+ echo "No modprobed.db data found"
exit
fi
fi
@@ -196,7 +190,7 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules
+ make -j$(nproc) bzImage modules
}
_package() {
@@ -213,7 +207,7 @@ _package() {
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- msg2 "Installing boot image..."
+ echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
@@ -221,13 +215,13 @@ _package() {
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
- msg2 "Installing modules..."
+ echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -237,7 +231,7 @@ _package-headers() {
cd ${_srcname}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Installing build files..."
+ echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
@@ -250,7 +244,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- msg2 "Installing headers..."
+ echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -266,10 +260,10 @@ _package-headers() {
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- msg2 "Installing KConfig files..."
+ echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
- msg2 "Removing unneeded architectures..."
+ echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
@@ -277,16 +271,16 @@ _package-headers() {
rm -r "$arch"
done
- msg2 "Removing documentation..."
+ echo "Removing documentation..."
rm -r "$builddir/Documentation"
- msg2 "Removing broken symlinks..."
+ echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- msg2 "Removing loose objects..."
+ echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- msg2 "Stripping build tools..."
+ echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
@@ -301,11 +295,11 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Adding symlink..."
+ echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -317,11 +311,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('78f3c397513cf4ff0f96aa7d09a921d003e08fa97c09e0bb71d88211b40567b2'
- 'SKIP'
- '3ffab23babc1635aa1a670ff7d44987e9aa1346d3394f1e2cbd37a9fcbefcac0'
+sha256sums=('37cbd2341d7d27188ae2de4c676bf614d1d55b42467e36187189e5b21bd26dac'
'SKIP'
- '8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5')
+ '7a4a209de815f4bae49c7c577c0584c77257e3953ac4324d2aa425859ba657f5')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds