summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2022-04-11 10:22:14 +0200
committerJosip Ponjavic2022-04-11 10:22:14 +0200
commit376120cacf06b074a215605bf0778dbfc5af4378 (patch)
tree4c27cdeec341ec69d560ade483d0cad8c96b761e /PKGBUILD
parente566ca1fff75ce4dca0c515c6859b710fb9225ca (diff)
downloadaur-376120cacf06b074a215605bf0778dbfc5af4378.tar.gz
sync with arch: FS#72275: Don't package files created by depmod
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 536492760a6b..ea4ec7fb3114 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,7 +84,7 @@ pkgdesc='Clear Linux lts2018'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-lts2018"
license=('GPL2')
-makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'pahole' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'libelf' 'pahole' 'xmlto')
options=('!strip')
_gcc_more_v='20211114'
source=(
@@ -253,7 +253,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}