aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo De Carlo2016-06-13 16:01:17 +0200
committerMatteo De Carlo2016-06-13 16:01:17 +0200
commit64bcc79920873f483498d2a276f006639d538609 (patch)
tree05a86c63ca6280c6f377e7337199795d3b0cd0e2 /PKGBUILD
parent4625f8c8fa94655f54de6f53d1dee7901c19bf85 (diff)
downloadaur-64bcc79920873f483498d2a276f006639d538609.tar.gz
update to 4.6.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a12af0c38b39..253ce68c3170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-covolunablu-gaming # Build kernel with a different name
-_srcname=linux-4.5
-pkgver=4.5.4
+_srcname=linux-4.6
+pkgver=4.6.2
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
-makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
+makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
# Because is already included in the kernel itself, no need to use dkms.
@@ -24,19 +24,21 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
+ '0001-linux-4.6-rtlwifi-fix-atomic.patch'
'http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.5.0-v7r11/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r11-4.5.0.patch'
'http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.5.0-v7r11/0002-block-introduce-the-BFQ-v7r11-I-O-sched-for-4.5.0.patch'
'http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.5.0-v7r11/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r11-for.patch'
"https://raw.githubusercontent.com/ValveSoftware/steamos_kernel/8e9ecc9caee1ae1d18c2cc4572729ef355091b6e/drivers/input/joystick/xpad.c")
-sha256sums=('a40defb401e01b37d6b8c8ad5c1bbab665be6ac6310cdeed59950c96b31a519c'
+sha256sums=('a93771cd5a8ad27798f22e9240538dfea48d3a2bf2a6a6ab415de3f02d25d866'
'SKIP'
- '6a9cfe691ac77346c48b7f83375a1880ebb379594de1000acad45da45d711e42'
+ '0dc509a19c68ab547a62158bf2017965b843854b63be46ae039c37724dccca21'
'SKIP'
- 'a5e555a756d859d5446ef0038fd208e960bb3844e5f3d7edef810d22f240978f'
- 'd04ce6f3864e23c850267082c144def7a419c5f4f961926b901757c912f58590'
+ '56d56e656a639b41902250e0ce4b27ad12ddd04b961f274aaec9e6f8831d161d'
+ '24db58e942eb415c5aeeca0d0c0b045ed3ee5ac0f71a8cbb3b69dbd649e1522a'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ 'ae0d16e81a915fae130125ba9d0b6fd2427e06f50b8b9514abc4029efe61ee98'
'5d19ecb91320a64f0abb6c8e70205fef848ada967093faa94e4c0c39c340d0c8'
'9c1e11772ff29d37dacc9246f63e24d5154eb61682ba2b7e175a9ccbdc7116e1'
'e0c9474431b60ca9fc3da04e7610748219da143440f1d7f5152572c7c63b52e0'
@@ -63,6 +65,10 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # fix rtlwifi atomic
+ # https://bugs.archlinux.org/task/49401
+ patch -p1 -i "${srcdir}/0001-linux-4.6-rtlwifi-fix-atomic.patch"
+
# add BFQ
patch -p1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r11-4.5.0.patch"
patch -p1 -i "${srcdir}/0002-block-introduce-the-BFQ-v7r11-I-O-sched-for-4.5.0.patch"
@@ -185,7 +191,7 @@ _package-headers() {
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/include"
for i in acpi asm-generic config crypto drm generated keys linux math-emu \
- media net pcmcia scsi sound trace uapi video xen; do
+ media net pcmcia scsi soc sound trace uapi video xen; do
cp -a include/${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/include/"
done
@@ -267,6 +273,12 @@ _package-headers() {
cp ${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/${i}"
done
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ if [ -f tools/objtool/objtool ]; then
+ mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool"
+ cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/
+ fi
+
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;